Repair glibc make check with -Wformat options enabled.
[platform/upstream/glibc.git] / packaging / glibc.spec
index fd7882a..0094a7f 100644 (file)
@@ -257,6 +257,11 @@ BuildFlags=$(echo %{optflags} | sed -e "s/-Wp,-D_FORTIFY_SOURCE=2//g" | sed -e "
 BuildFlags="$BuildFlags -O2 -g -U_FORTIFY_SOURCE"
 BuildFlags="$(echo $BuildFlags | sed -e 's#-fstack-protector##' -e 's#-ffortify=[0-9]*##')"
 BuildFlags="$(echo $BuildFlags | sed -e 's/-Wa,-mimplicit-it=thumb//g' | sed -e 's/-mthumb//g')"
+# Turn off all -Wformat enable flags as there are glibc tests that explicitly
+# append -Wno-format and with enabled Wformat options that produced warnings
+# that turns into errors. Remove -Wformat=1|2 or -Wformat-..-arg
+BuildFlags="$(echo $BuildFlags | sed -re 's/-Wformat((=[1-2])|((-\w+)+))?(\s|$)//g')"
+
 BuildCC="%__cc"
 BuildCCplus="%__cxx"
 add_ons=",libidn"