changes: Bug-Tizen: TZPC-3317 (... remove the fav apps icon ...)
[platform/upstream/glib.git] / packaging / glib2.spec
index f2c7e91..f94c310 100644 (file)
@@ -2,15 +2,14 @@
 %define keepstatic 1
 
 Name:           glib2
-%define _name glib
-Version:        2.34.3
+Version:        2.36.1
 Release:        0
 # FIXME: find out if tapsets should really be in devel package or in main package
 Summary:        General-Purpose Utility Library
 License:        LGPL-2.1+
 Group:          System/Libraries
 Url:            http://www.gtk.org/
-Source:         http://download.gnome.org/sources/glib/2.32/%{_name}-%{version}.tar.xz
+Source:         http://download.gnome.org/sources/glib/2.32/%{name}-%{version}.tar.xz
 Source1:        glib2.sh
 Source2:        glib2.csh
 # Not upstream file. Only proposes upstream packages:
@@ -36,13 +35,6 @@ BuildRequires:  pkgconfig(libelf) >= 0.8.12
 BuildRequires:  pkgconfig(libffi)
 BuildRequires:  pkgconfig(libpcre)
 BuildRequires:  pkgconfig(zlib)
-%if 0%{?BUILD_FROM_VCS}
-# It's important to keep those BuildRequires inside
-# BUILD_FROM_VCS to avoid build loops in Factory
-BuildRequires:  git-core
-BuildRequires:  gtk-doc
-%endif
-BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
 GLib is a general-purpose utility library, which provides many useful
@@ -51,7 +43,7 @@ a main loop abstraction, and so on.
 
 %package tools
 Summary:        General-Purpose Utility Library -- Tools
-Group:          Development/Libraries/C and C++
+Group:          Development/Libraries
 
 %description tools
 GLib is a general-purpose utility library, which provides many useful
@@ -100,7 +92,7 @@ Requires:       python-xml
 Provides:       glib2-doc = 2.19.6
 Obsoletes:      glib2-doc < 2.19.6
 Summary:        General-Purpose Utility Library -- Development Files
-Group:          Development/Libraries/C and C++
+Group:          Development/Libraries
 
 %description devel
 GLib is a general-purpose utility library, which provides many useful
@@ -112,7 +104,7 @@ This package contains the development files for GLib.
 %package devel-static
 Requires:       %{name}-devel = %{version}
 Summary:        General-Purpose Utility Library -- Static Libraries
-Group:          Development/Libraries/C and C++
+Group:          Development/Libraries
 
 %description devel-static
 GLib is a general-purpose utility library, which provides many useful
@@ -186,17 +178,15 @@ a main loop abstraction, and so on.
 The GObject library provides an object-oriented framework for C.
 
 %prep
-%setup -q -n %{_name}-%{version}
+%setup -q -n %{name}-%{version}
 cp -a %{S:1} %{S:2} .
 cp -a %{S:4} gnome_defaults.conf
 if ! test -f %{_datadir}/aclocal/gtk-doc.m4 ; then
     cp -a %{S:7} m4macros/
 fi
-%if 0%{?BUILD_FROM_VCS}
-NOCONFIGURE=1 ./autogen.sh
-%endif
 
 %build
+NOCONFIGURE=1 ./autogen.sh
 %configure \
     --enable-static \
 %if 0%{?with_systemtap}
@@ -205,18 +195,12 @@ NOCONFIGURE=1 ./autogen.sh
     --with-pcre=system
 
 %{__make} %{?_smp_mflags} V=1
-%if 0%{?BUILD_FROM_VCS}
-%{__make} ChangeLog
-%endif
 
-%check
-# make check does not work on x86_64. See http://bugzilla.gnome.org/show_bug.cgi?id=554969
-# %{__make} %{?jobs:-j%jobs} check
 
 %install
 %make_install
-%find_lang %{_name}20 %{?no_lang_C}
-mv %{_name}20.lang %{_name}2.lang
+%find_lang glib20 %{?no_lang_C}
+
 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
 install -D -m0644 glib2.sh %{buildroot}%{_sysconfdir}/profile.d/zzz-glib2.sh
 install -D -m0644 glib2.csh %{buildroot}%{_sysconfdir}/profile.d/zzz-glib2.csh
@@ -267,7 +251,6 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 %defattr(-,root,root)
 %dir %{_datadir}/bash-completion
 %dir %{_datadir}/bash-completion/completions
-%{_datadir}/bash-completion/completions/gdbus
 %{_datadir}/bash-completion/completions/gresource
 %{_datadir}/bash-completion/completions/gsettings
 %{_bindir}/gdbus
@@ -286,7 +269,7 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 
 %files -n libglib
 %defattr(-, root, root)
-%doc COPYING
+%license COPYING
 %{_libdir}/libglib*.so.*
 
 %files -n libgmodule
@@ -317,14 +300,16 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 %ghost %{_localstatedir}/cache/gio-2.0/lxde-defaults.list
 
 
-%lang_package
+%lang_package -f glib20
 
-%docs_package
 
 %files devel
 %defattr(-,root,root)
-%doc ChangeLog
+
 %{_bindir}/gdbus-codegen
+%{_datadir}/bash-completion/completions/*
+%_datadir/glib-2.0/codegen
+
 %{_bindir}/glib-compile-resources
 %{_bindir}/glib-genmarshal
 %{_bindir}/glib-gettextize
@@ -344,21 +329,13 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 %{_includedir}/gio-unix-2.0
 %{_libdir}/lib*.so
 %dir %{_libdir}/glib-2.0/
-%dir %{_libdir}/gdbus-2.0/
-%{_libdir}/gdbus-2.0/codegen/
 %{_libdir}/glib-2.0/include/
 %{_libdir}/pkgconfig/*.pc
-%{_datadir}/gtk-doc/html/gio
-%{_datadir}/gtk-doc/html/glib
-%{_datadir}/gtk-doc/html/gobject
 %{_datadir}/gdb/auto-load/%{_libdir}/*-gdb.py
 %if 0%{?with_systemtap}
 %{_datadir}/systemtap/tapset/*.stp
 %endif
 %{_sysconfdir}/rpm/macros.glib2
-# Own these directories to not depend on gtk-doc while building:
-%dir %{_datadir}/gtk-doc
-%dir %{_datadir}/gtk-doc/html
 # Own these directories to not depend on gdb
 %dir %{_datadir}/gdb
 %dir %{_datadir}/gdb/auto-load