[kdbus] Update kdbus interface header (commit: b620b72c9127) 14/10/16
[platform/upstream/glib.git] / packaging / glib2.spec
index b92522a..812ec87 100644 (file)
@@ -1,16 +1,16 @@
+%define baseline 2.40
 %define with_systemtap 0
 %define keepstatic 1
 
 Name:           glib2
-%define _name glib
-Version:        2.35.4
+Version:        2.43.1
 Release:        0
 # FIXME: find out if tapsets should really be in devel package or in main package
 Summary:        General-Purpose Utility Library
 License:        LGPL-2.1+
-Group:          System/Libraries
+Group:          Base/Libraries
 Url:            http://www.gtk.org/
-Source:         http://download.gnome.org/sources/glib/2.32/%{_name}-%{version}.tar.xz
+Source:         http://download.gnome.org/sources/glib/%{baseline}/%{name}-%{version}.tar.xz
 Source1:        glib2.sh
 Source2:        glib2.csh
 # Not upstream file. Only proposes upstream packages:
@@ -20,6 +20,7 @@ Source6:        macros.glib2
 # Please update this file from the latest gtk-doc package:
 Source7:        gtk-doc.m4
 Source99:       baselibs.conf
+Source1001:    glib2.manifest
 BuildRequires:  automake
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
@@ -44,7 +45,6 @@ a main loop abstraction, and so on.
 
 %package tools
 Summary:        General-Purpose Utility Library -- Tools
-Group:          Development/Libraries/C and C++
 
 %description tools
 GLib is a general-purpose utility library, which provides many useful
@@ -53,7 +53,6 @@ a main loop abstraction, and so on.
 
 %package -n gio-branding-upstream
 Summary:        Upstream definitions of default settings and applications
-Group:          System/Libraries
 Requires:       libgio = %{version}
 Provides:       %{name}-branding-upstream = %{version}
 Obsoletes:      %{name}-branding-upstream < %{version}
@@ -93,7 +92,6 @@ Requires:       python-xml
 Provides:       glib2-doc = 2.19.6
 Obsoletes:      glib2-doc < 2.19.6
 Summary:        General-Purpose Utility Library -- Development Files
-Group:          Development/Libraries/C and C++
 
 %description devel
 GLib is a general-purpose utility library, which provides many useful
@@ -105,7 +103,6 @@ This package contains the development files for GLib.
 %package devel-static
 Requires:       %{name}-devel = %{version}
 Summary:        General-Purpose Utility Library -- Static Libraries
-Group:          Development/Libraries/C and C++
 
 %description devel-static
 GLib is a general-purpose utility library, which provides many useful
@@ -116,7 +113,6 @@ This package contains static versions of the GLib libraries.
 
 %package -n libglib
 Summary:        General-Purpose Utility Library
-Group:          System/Libraries
 Provides:       %{name} = %{version}
 Obsoletes:      %{name} < %{version}
 
@@ -127,7 +123,6 @@ a main loop abstraction, and so on.
 
 %package -n libgmodule
 Summary:        General-Purpose Utility Library -- Library for Modules
-Group:          System/Libraries
 
 %description -n libgmodule
 GLib is a general-purpose utility library, which provides many useful
@@ -139,7 +134,6 @@ object files (commonly known as 'plug-ins').
 
 %package -n libgio
 Summary:        General-Purpose Utility Library -- Library for VFS
-Group:          System/Libraries
 Requires:       gio-branding = %{version}
 # bnc#555605: shared-mime-info is required by libgio to properly detect mime types.
 Requires:       shared-mime-info
@@ -157,7 +151,6 @@ GIO provides a modern, easy-to-use VFS API.
 
 %package -n libgthread
 Summary:        General-Purpose Utility Library -- Library for Threads
-Group:          System/Libraries
 
 %description -n libgthread
 GLib is a general-purpose utility library, which provides many useful
@@ -169,7 +162,6 @@ software.
 
 %package -n libgobject
 Summary:        General-Purpose Utility Library -- Object-Oriented Framework for C
-Group:          System/Libraries
 
 %description -n libgobject
 GLib is a general-purpose utility library, which provides many useful
@@ -179,7 +171,8 @@ a main loop abstraction, and so on.
 The GObject library provides an object-oriented framework for C.
 
 %prep
-%setup -q -n %{_name}-%{version}
+%setup -q -n %{name}-%{version}
+cp %{SOURCE1001} .
 cp -a %{S:1} %{S:2} .
 cp -a %{S:4} gnome_defaults.conf
 if ! test -f %{_datadir}/aclocal/gtk-doc.m4 ; then
@@ -197,14 +190,11 @@ NOCONFIGURE=1 ./autogen.sh
 
 %{__make} %{?_smp_mflags} V=1
 
-%check
-# make check does not work on x86_64. See http://bugzilla.gnome.org/show_bug.cgi?id=554969
-# %{__make} %{?jobs:-j%jobs} check
 
 %install
 %make_install
-%find_lang %{_name}20 %{?no_lang_C}
-mv %{_name}20.lang %{_name}2.lang
+%find_lang glib20 %{?no_lang_C}
+
 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
 install -D -m0644 glib2.sh %{buildroot}%{_sysconfdir}/profile.d/zzz-glib2.sh
 install -D -m0644 glib2.csh %{buildroot}%{_sysconfdir}/profile.d/zzz-glib2.csh
@@ -252,6 +242,7 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 
 
 %files tools
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %dir %{_datadir}/bash-completion
 %dir %{_datadir}/bash-completion/completions
@@ -262,33 +253,40 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 %{_bindir}/glib-compile-schemas
 %{_bindir}/gresource
 %{_bindir}/gsettings
+%{_bindir}/gapplication
 # We put those files here, but they don't really belong here. They just don't
 # have a better home... The zzz-glib2 scripts could arguably be in
 # libglib but that would break the shared library policy.
 %{_sysconfdir}/profile.d/zzz-glib2.*
 
 %files -n gio-branding-upstream
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %config (noreplace) %{_sysconfdir}/gnome_defaults.conf
 
 %files -n libglib
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %license COPYING
 %{_libdir}/libglib*.so.*
 
 %files -n libgmodule
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %{_libdir}/libgmodule*.so.*
 
 %files -n libgobject
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %{_libdir}/libgobject*.so.*
 
 %files -n libgthread
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %{_libdir}/libgthread*.so.*
 
 %files -n libgio
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %{_libdir}/libgio*.so.*
 %dir %{_libdir}/gio
@@ -304,11 +302,11 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 %ghost %{_localstatedir}/cache/gio-2.0/lxde-defaults.list
 
 
-%lang_package
+%lang_package -f glib20
 
-%docs_package
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 
 %{_bindir}/gdbus-codegen
@@ -348,6 +346,7 @@ cp %{S:6} %{buildroot}%{_sysconfdir}/rpm
 %dir %{_datadir}/gdb/auto-load%{_libdir}
 
 %files devel-static
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_libdir}/lib*.a