change the sysroot and c++ include path to fix the bugs the application cannot find...
[platform/upstream/gcc48.git] / packaging / gcc48.spec
index 776b2dd..d5ce04d 100644 (file)
@@ -23,7 +23,7 @@
 
 %define quadmath_arch %ix86 x86_64 ia64
 %define tsan_arch x86_64
-%define asan_arch x86_64 %ix86 ppc ppc64
+%define asan_arch x86_64 %ix86 ppc ppc64 %arm
 %define itm_arch x86_64 %ix86 %arm ppc ppc64
 %define atomic_arch x86_64 %ix86 %arm ppc ppc64 s390 s390x
 
@@ -32,9 +32,9 @@
 %define build_libjava 0
 
 %define build_cp 1
-%define build_fortran !0%{?building_libjava:1}%{?building_libffi:1}
-%define build_objc !0%{?building_libjava:1}%{?building_libffi:1}
-%define build_objcp !0%{?building_libjava:1}%{?building_libffi:1}
+%define build_fortran 0%{?building_libjava:1}%{?building_libffi:1}
+%define build_objc 0%{?building_libjava:1}%{?building_libffi:1}
+%define build_objcp 0%{?building_libjava:1}%{?building_libffi:1}
 %define build_with_mudflap 0
 
 %if %{build_objcp}
@@ -174,9 +174,7 @@ BuildRequires: gdb
 URL:          http://gcc.gnu.org/
 Version: 4.8.1
 Release:      1
-%define gcc_version %(echo %version | sed 's/_.*//')
-%define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
-%define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
+%define gcc_dir_version 4.8
 %define binsuffix -4.8
 
 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
@@ -204,14 +202,14 @@ Suggests: gcc48-info gcc48-locale
 %endif
 
 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
-Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
+Source:                gcc-%{version}.tar.bz2
 Source1:       change_spec
 Source3:       gcc48-rpmlintrc
 Source4:       ecj.jar
 Source6:       baselibs.conf
 
 
-Group:         Development/Languages/C and C++
+Group:         Development/Toolchain
 Summary:       The GNU C Compiler and Support Files
 License:        GPL-3.0+
 
@@ -227,7 +225,6 @@ gcc-obj-c++.
 
 %package -n gcc48-32bit
 Summary:      The GNU C Compiler 32bit support
-Group:        Development/Languages/C and C++
 Requires: gcc48 = %{version}-%{release}
 Requires: libgcc_s%{libgcc_s}-32bit >= %{version}-%{release}
 Requires: libgomp%{libgomp_sover}-32bit >= %{version}-%{release}
@@ -242,7 +239,6 @@ This package contains 32bit support for the GNU Compiler Collection.
 
 %package -n gcc48-64bit
 Summary:      The GNU C Compiler 64bit support
-Group:        Development/Languages/C and C++
 Requires: gcc48 = %{version}-%{release}
 Requires: libgcc_s%{libgcc_s}-64bit >= %{version}-%{release}
 Requires: libgomp%{libgomp_sover}-64bit >= %{version}-%{release}
@@ -259,7 +255,6 @@ This package contains 64bit support for the GNU Compiler Collection.
 %package locale
 Summary:      Locale Data for the GNU Compiler Collection
 License:        GPL-3.0+
-Group:        Development/Languages/C and C++
 Requires: gcc48 = %{version}-%{release}
 
 %description locale
@@ -270,7 +265,6 @@ in the current locale.
 %package c++
 Summary:      The GNU C++ Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/C and C++
 Requires: gcc48 = %{version}-%{release}
 Requires: libstdc++48-devel = %{version}-%{release}
 
@@ -280,7 +274,6 @@ This package contains the GNU compiler for C++.
 %package -n libstdc++48-devel
 Summary:      Include Files and Libraries mandatory for Development
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 Requires: libstdc++%{libstdcxx_sover} >= %{version}-%{release}
 Requires: glibc-devel
 %ifarch ia64
@@ -293,7 +286,6 @@ library. It is needed for compiling C++ code.
 %package -n libstdc++48-devel-32bit
 Summary:      Include Files and Libraries mandatory for Development
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 Requires: libstdc++%{libstdcxx_sover}-32bit >= %{version}-%{release}
 Requires: glibc-devel-32bit
 %ifarch ia64
@@ -306,7 +298,6 @@ library. It is needed for compiling C++ code.
 %package -n libstdc++48-devel-64bit
 Summary:      Include Files and Libraries mandatory for Development
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 Requires: libstdc++%{libstdcxx_sover}-64bit >= %{version}-%{release}
 Requires: glibc-devel-64bit
 %ifarch ia64
@@ -320,7 +311,6 @@ library. It is needed for compiling C++ code.
 %package -n libstdc++48-doc
 Summary:      Documentation for the GNU C++ standard library
 License:        GPL-3.0+
-Group:        Documentation/HTML
 BuildArch:    noarch
 
 %description -n libstdc++48-doc
@@ -330,7 +320,7 @@ Extensive HTML documentation for the GNU C++ standard library.
 %package -n libgcc_s%{libgcc_s}%{libgcc_s_suffix}
 Summary:      C compiler runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Base
+Group:        System/Libraries
 Provides:      libgcc_s%{libgcc_s} = %{version}-%{release}
 
 %description -n libgcc_s%{libgcc_s}%{libgcc_s_suffix}
@@ -344,7 +334,7 @@ Libgcc is needed for dynamically linked C programs.
 %package -n libgcc_s%{libgcc_s}%{libgcc_s_suffix}-32bit
 Summary:      C compiler runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Base
+Group:        System/Libraries
 Provides:      libgcc_s%{libgcc_s}-32bit = %{version}-%{release}
 
 %description -n libgcc_s%{libgcc_s}%{libgcc_s_suffix}-32bit
@@ -358,7 +348,7 @@ Libgcc is needed for dynamically linked C programs.
 %package -n libgcc_s%{libgcc_s}%{libgcc_s_suffix}-64bit
 Summary:      C compiler runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Base
+Group:        System/Libraries
 Provides:      libgcc_s%{libgcc_s}-64bit = %{version}-%{release}
 
 %description -n libgcc_s%{libgcc_s}%{libgcc_s_suffix}-64bit
@@ -373,7 +363,7 @@ Libgcc is needed for dynamically linked C programs.
 %package -n libgomp%{libgomp_sover}%{libgomp_suffix}
 Summary:      The GNU compiler collection OpenMP runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Base
+Group:        System/Libraries
 Provides:      libgomp%{libgomp_sover} = %{version}-%{release}
 
 %description -n libgomp%{libgomp_sover}%{libgomp_suffix}
@@ -391,7 +381,7 @@ option.
 %package -n libgomp%{libgomp_sover}%{libgomp_suffix}-32bit
 Summary:      The GNU compiler collection OpenMP runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Base
+Group:        System/Libraries
 Provides:      libgomp%{libgomp_sover}-32bit = %{version}-%{release}
 
 %description -n libgomp%{libgomp_sover}%{libgomp_suffix}-32bit
@@ -409,7 +399,7 @@ option.
 %package -n libgomp%{libgomp_sover}%{libgomp_suffix}-64bit
 Summary:      The GNU compiler collection OpenMP runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Base
+Group:        System/Libraries
 Provides:      libgomp%{libgomp_sover}-64bit = %{version}-%{release}
 
 %description -n libgomp%{libgomp_sover}%{libgomp_suffix}-64bit
@@ -487,7 +477,6 @@ The standard C++ library locale data.
 %package info
 Summary:      Documentation for the GNU compiler collection
 License:      GFDL-1.2
-Group:        Documentation/Other
 BuildArch:    noarch
 
 %description info
@@ -498,7 +487,6 @@ and internals documentation.
 %package objc
 Summary:      GNU Objective C Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/Other
 Requires: gcc48 = %{version}-%{release}
 Requires: libobjc%{libobjc_sover} >= %{version}-%{release}
 
@@ -509,7 +497,6 @@ Nextstep OS. The source code is available in the gcc package.
 %package objc-32bit
 Summary:      GNU Objective C Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/Other
 Requires: gcc48 = %{version}-%{release}
 Requires: libobjc%{libobjc_sover}-32bit >= %{version}-%{release}
 
@@ -520,7 +507,6 @@ Nextstep OS. The source code is available in the gcc package.
 %package objc-64bit
 Summary:      GNU Objective C Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/Other
 Requires: gcc48 = %{version}-%{release}
 Requires: libobjc%{libobjc_sover}-64bit >= %{version}-%{release}
 
@@ -532,7 +518,6 @@ Nextstep OS. The source code is available in the gcc package.
 %package -n libobjc%{libobjc_sover}%{libobjc_suffix}
 Summary:      Library for the GNU Objective C Compiler
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Libraries/Other
 Provides:      libobjc%{libobjc_sover} = %{version}-%{release}
 
 %description -n libobjc%{libobjc_sover}%{libobjc_suffix}
@@ -546,7 +531,6 @@ The library for the GNU Objective C compiler.
 %package -n libobjc%{libobjc_sover}%{libobjc_suffix}-32bit
 Summary:      Library for the GNU Objective C Compiler
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Libraries/Other
 Provides:      libobjc%{libobjc_sover}-32bit = %{version}-%{release}
 
 %description -n libobjc%{libobjc_sover}%{libobjc_suffix}-32bit
@@ -560,7 +544,6 @@ The library for the GNU Objective C compiler.
 %package -n libobjc%{libobjc_sover}%{libobjc_suffix}-64bit
 Summary:      Library for the GNU Objective C Compiler
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Libraries/Other
 Provides:      libobjc%{libobjc_sover}-64bit = %{version}-%{release}
 
 %description -n libobjc%{libobjc_sover}%{libobjc_suffix}-64bit
@@ -575,7 +558,6 @@ The library for the GNU Objective C compiler.
 %package obj-c++
 Summary:      GNU Objective C++ Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/Other
 Requires: gcc48-objc = %{version}-%{release}
 Requires: gcc48-c++ = %{version}-%{release}
 
@@ -588,7 +570,6 @@ Nextstep OS. The source code is available in the gcc package.
 %package -n cpp48
 Summary:      The GCC Preprocessor
 License:        GPL-3.0+
-Group:        Development/Languages/C and C++
 
 %description -n cpp48
 This Package contains just the preprocessor that is used by the X11
@@ -598,7 +579,6 @@ packages.
 %package ada
 Summary:      GNU Ada95 Compiler Based on GCC (GNAT)
 License:        GPL-3.0+
-Group:        Development/Languages/Other
 Requires: gcc48 = %{version}-%{release}
 Requires: libada48 = %{version}-%{release}
 
@@ -610,7 +590,6 @@ must have installed a binary version to bootstrap the compiler.
 %package ada-32bit
 Summary:      GNU Ada95 Compiler Based on GCC (GNAT)
 License:        GPL-3.0+
-Group:        Development/Languages/Other
 Requires: gcc48-32bit = %{version}-%{release}
 Requires: libada48-32bit = %{version}-%{release}
 
@@ -622,7 +601,6 @@ must have installed a binary version to bootstrap the compiler.
 %package ada-64bit
 Summary:      GNU Ada95 Compiler Based on GCC (GNAT)
 License:        GPL-3.0+
-Group:        Development/Languages/Other
 Requires: gcc48-64bit = %{version}-%{release}
 Requires: libada48-64bit = %{version}-%{release}
 
@@ -635,7 +613,6 @@ must have installed a binary version to bootstrap the compiler.
 %package -n libada48
 Summary:      GNU Ada Runtime Libraries
 License:      GPL-3.0-with-GCC-exception
-Group:        System/Libraries
 %description -n libada48
 This package contains the shared libraries required to run programs
 compiled with the GNU Ada compiler (GNAT) if they are compiled to use
@@ -652,7 +629,6 @@ implementation of Distributed Systems Programming (GLADE) and the Posix
 %package -n libada48-32bit
 Summary:      GNU Ada Runtime Libraries
 License:      GPL-3.0-with-GCC-exception
-Group:        System/Libraries
 %description -n libada48-32bit
 This package contains the shared libraries required to run programs
 compiled with the GNU Ada compiler (GNAT) if they are compiled to use
@@ -669,7 +645,6 @@ implementation of Distributed Systems Programming (GLADE) and the Posix
 %package -n libada48-64bit
 Summary:      GNU Ada Runtime Libraries
 License:      GPL-3.0-with-GCC-exception
-Group:        System/Libraries
 %description -n libada48-64bit
 This package contains the shared libraries required to run programs
 compiled with the GNU Ada compiler (GNAT) if they are compiled to use
@@ -687,7 +662,6 @@ implementation of Distributed Systems Programming (GLADE) and the Posix
 %package fortran
 Summary:      The GNU Fortran Compiler and Support Files
 License:        GPL-3.0+
-Group:        Development/Languages/Fortran
 Requires: gcc48 = %{version}-%{release}
 Requires: libgfortran%{libgfortran_sover} >= %{version}-%{release}
 %ifarch %quadmath_arch
@@ -699,7 +673,6 @@ This is the Fortran compiler of the GNU Compiler Collection (GCC).
 %package fortran-32bit
 Summary:      The GNU Fortran Compiler and Support Files
 License:        GPL-3.0+
-Group:        Development/Languages/Fortran
 Requires: gcc48 = %{version}-%{release}
 Requires: libgfortran%{libgfortran_sover}-32bit >= %{version}-%{release}
 %ifarch %quadmath_arch
@@ -711,7 +684,6 @@ This is the Fortran compiler of the GNU Compiler Collection (GCC).
 %package fortran-64bit
 Summary:      The GNU Fortran Compiler and Support Files
 License:        GPL-3.0+
-Group:        Development/Languages/Fortran
 Requires: gcc48 = %{version}-%{release}
 Requires: libgfortran%{libgfortran_sover}-64bit >= %{version}-%{release}
 %ifarch %quadmath_arch
@@ -724,7 +696,6 @@ This is the Fortran compiler of the GNU Compiler Collection (GCC).
 %package -n libgfortran%{libgfortran_sover}%{libgfortran_suffix}
 Summary:      The GNU Fortran Compiler Runtime Library
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/Fortran
 %ifarch %quadmath_arch
 Requires: libquadmath%{libquadmath_sover} >= %{version}-%{release}
 %endif
@@ -742,7 +713,6 @@ of the GNU Compiler Collection (GCC).
 %package -n libgfortran%{libgfortran_sover}%{libgfortran_suffix}-32bit
 Summary:      The GNU Fortran Compiler Runtime Library
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/Fortran
 %ifarch %quadmath_arch
 Requires: libquadmath%{libquadmath_sover}-32bit >= %{version}-%{release}
 %endif
@@ -760,7 +730,6 @@ of the GNU Compiler Collection (GCC).
 %package -n libgfortran%{libgfortran_sover}%{libgfortran_suffix}-64bit
 Summary:      The GNU Fortran Compiler Runtime Library
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/Fortran
 %ifarch %quadmath_arch
 Requires: libquadmath%{libquadmath_sover}-64bit >= %{version}-%{release}
 %endif
@@ -779,7 +748,6 @@ of the GNU Compiler Collection (GCC).
 %package -n libquadmath%{libquadmath_sover}%{libquadmath_suffix}
 Summary:      The GNU Fortran Compiler Quadmath Runtime Library
 License:        LGPL-2.1
-Group:        Development/Languages/Fortran
 Provides:      libquadmath%{libquadmath_sover} = %{version}-%{release}
 
 %description -n libquadmath%{libquadmath_sover}%{libquadmath_suffix}
@@ -795,7 +763,6 @@ operations.
 %package -n libquadmath%{libquadmath_sover}%{libquadmath_suffix}-32bit
 Summary:      The GNU Fortran Compiler Quadmath Runtime Library
 License:        LGPL-2.1
-Group:        Development/Languages/Fortran
 Provides:      libquadmath%{libquadmath_sover}-32bit = %{version}-%{release}
 
 %description -n libquadmath%{libquadmath_sover}%{libquadmath_suffix}-32bit
@@ -811,7 +778,6 @@ operations.
 %package -n libquadmath%{libquadmath_sover}%{libquadmath_suffix}-64bit
 Summary:      The GNU Fortran Compiler Quadmath Runtime Library
 License:        LGPL-2.1
-Group:        Development/Languages/Fortran
 Provides:      libquadmath%{libquadmath_sover}-64bit = %{version}-%{release}
 
 %description -n libquadmath%{libquadmath_sover}%{libquadmath_suffix}-64bit
@@ -828,7 +794,6 @@ operations.
 %package -n libmudflap48
 Summary:      The Mudflap Extension Runtime Library
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 
 %description -n libmudflap48
 This is the Mudflap Extension Runtime Library.
@@ -841,7 +806,6 @@ This is the Mudflap Extension Runtime Library.
 %package -n libmudflap48-32bit
 Summary:      The Mudflap Extension Runtime Library
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 
 %description -n libmudflap48-32bit
 This is the Mudflap Extension Runtime Library.
@@ -854,7 +818,6 @@ This is the Mudflap Extension Runtime Library.
 %package -n libmudflap48-64bit
 Summary:      The Mudflap Extension Runtime Library
 License:        GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 
 %description -n libmudflap48-64bit
 This is the Mudflap Extension Runtime Library.
@@ -868,7 +831,6 @@ This is the Mudflap Extension Runtime Library.
 %package -n libitm%{libitm_sover}%{libitm_suffix}
 Summary:      The GNU Compiler Transactional Memory Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libitm%{libitm_sover}%{libitm_suffix}
 The runtime library needed to run programs compiled with the
@@ -882,7 +844,6 @@ The runtime library needed to run programs compiled with the
 %package -n libitm%{libitm_sover}%{libitm_suffix}-32bit
 Summary:      The GNU Compiler Transactional Memory Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libitm%{libitm_sover}%{libitm_suffix}-32bit
 The runtime library needed to run programs compiled with the
@@ -896,7 +857,6 @@ The runtime library needed to run programs compiled with the
 %package -n libitm%{libitm_sover}%{libitm_suffix}-64bit
 Summary:      The GNU Compiler Transactional Memory Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libitm%{libitm_sover}%{libitm_suffix}-64bit
 The runtime library needed to run programs compiled with the
@@ -911,7 +871,6 @@ The runtime library needed to run programs compiled with the
 %package -n libasan%{libasan_sover}%{libasan_suffix}
 Summary:      The GNU Compiler Address Sanitizer Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libasan%{libasan_sover}%{libasan_suffix}
 The runtime library needed to run programs compiled with the
@@ -925,7 +884,6 @@ The runtime library needed to run programs compiled with the
 %package -n libasan%{libasan_sover}%{libasan_suffix}-32bit
 Summary:      The GNU Compiler Address Sanitizer Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libasan%{libasan_sover}%{libasan_suffix}-32bit
 The runtime library needed to run programs compiled with the
@@ -939,7 +897,6 @@ The runtime library needed to run programs compiled with the
 %package -n libasan%{libasan_sover}%{libasan_suffix}-64bit
 Summary:      The GNU Compiler Address Sanitizer Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libasan%{libasan_sover}%{libasan_suffix}-64bit
 The runtime library needed to run programs compiled with the
@@ -954,7 +911,6 @@ The runtime library needed to run programs compiled with the
 %package -n libtsan%{libtsan_sover}%{libtsan_suffix}
 Summary:      The GNU Compiler Thread Sanitizer Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libtsan%{libtsan_sover}%{libtsan_suffix}
 The runtime library needed to run programs compiled with the
@@ -968,7 +924,6 @@ The runtime library needed to run programs compiled with the
 %package -n libtsan%{libtsan_sover}%{libtsan_suffix}-32bit
 Summary:      The GNU Compiler Thread Sanitizer Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libtsan%{libtsan_sover}%{libtsan_suffix}-32bit
 The runtime library needed to run programs compiled with the
@@ -982,7 +937,6 @@ The runtime library needed to run programs compiled with the
 %package -n libtsan%{libtsan_sover}%{libtsan_suffix}-64bit
 Summary:      The GNU Compiler Thread Sanitizer Runtime Library
 License:        MIT
-Group:        Development/Languages/C and C++
 
 %description -n libtsan%{libtsan_sover}%{libtsan_suffix}-64bit
 The runtime library needed to run programs compiled with the
@@ -997,7 +951,6 @@ The runtime library needed to run programs compiled with the
 %package -n libatomic%{libatomic_sover}%{libatomic_suffix}
 Summary:      The GNU Compiler Atomic Operations Runtime Library
 License:      GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 
 %description -n libatomic%{libatomic_sover}%{libatomic_suffix}
 The runtime library for atomic operations of the GNU Compiler Collection (GCC).
@@ -1010,7 +963,6 @@ The runtime library for atomic operations of the GNU Compiler Collection (GCC).
 %package -n libatomic%{libatomic_sover}%{libatomic_suffix}-32bit
 Summary:      The GNU Compiler Atomic Operations Runtime Library
 License:      GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 
 %description -n libatomic%{libatomic_sover}%{libatomic_suffix}-32bit
 The runtime library for atomic operations of the GNU Compiler Collection (GCC).
@@ -1023,7 +975,6 @@ The runtime library for atomic operations of the GNU Compiler Collection (GCC).
 %package -n libatomic%{libatomic_sover}%{libatomic_suffix}-64bit
 Summary:      The GNU Compiler Atomic Operations Runtime Library
 License:      GPL-3.0-with-GCC-exception
-Group:        Development/Languages/C and C++
 
 %description -n libatomic%{libatomic_sover}%{libatomic_suffix}-64bit
 The runtime library for atomic operations of the GNU Compiler Collection (GCC).
@@ -1054,7 +1005,6 @@ Source code for this package is in gcc.
 %package -n gcc48-java
 Summary:      The GNU Java Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/Java
 Requires: gcc48 = %{version}
 Requires: libgcj48-devel = %{version}-%{release}
 
@@ -1065,7 +1015,6 @@ The Java compiler from the GCC-tools-suite.
 %package -n libgcj_bc%{libgcj_bc_sover}%{libgcj_bc_suffix}
 Summary:      Fake library for BC-ABI compatibility.
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 # libgcj_bc is special in that it just contains a symlink to
 # a proper libgcj version.  So require that library and add
 # provides for the shlib version as created at link time
@@ -1086,7 +1035,6 @@ libgcj.so changes.
 %package -n libgcj48-jar
 Summary:      Java runtime library (jar files).
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 
 %description -n libgcj48-jar
 These are the jar files that go along with the gcj front end to gcc.
@@ -1095,7 +1043,6 @@ These are the jar files that go along with the gcj front end to gcc.
 %package -n libgcj48-devel
 Summary:      Include Files and Libraries mandatory for Development.
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 Requires: libstdc++48-devel = %{version}
 Requires: libgcj%{libgcj_sover} >= %{version}-%{release}
 Requires: libgcj_bc%{libgcj_bc_sover} >= %{version}-%{release}
@@ -1116,7 +1063,6 @@ to develop applications that require these.
 %package -n gcc48-gij
 Summary:      Java Bytecode Interpreter for gcc
 License:      GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 Requires: libgcj%{libgcj_sover} >= %{version}-%{release}
 
 %description -n gcc48-gij
@@ -1125,7 +1071,6 @@ This package contains the java bytecode interpreter gij and related tools.
 %package -n libffi%{libffi_sover}%{libffi_suffix}
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -1138,7 +1083,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -1151,7 +1095,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -1165,7 +1108,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover} >= %{version}-%{release}
 
 %description -n libffi48-devel
@@ -1173,7 +1115,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-32bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-32bit >= %{version}-%{release}
 
 %description -n libffi48-devel-32bit
@@ -1181,7 +1122,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-64bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-64bit >= %{version}-%{release}
 
 %description -n libffi48-devel-64bit
@@ -1190,7 +1130,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n gcc48-testresults
 Summary:      Testsuite results
 License:       SUSE-Public-Domain
-Group:        Development/Languages/C and C++
 
 %description -n gcc48-testresults
 Results from running the gcc and target library testsuites.
@@ -1307,7 +1246,7 @@ Results from running the gcc and target library testsuites.
 
 
 %prep
-%setup -q -n gcc-%{gcc_version}%{snapshot_date}
+%setup -q -n gcc-%{version}
 
 
 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
@@ -1459,6 +1398,9 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --disable-plugin \
        --with-bugurl="http://bugs.tizen.org/" \
        --with-pkgversion="Tizen" \
+%if !%{build_fortran}
+       --disable-libquadmath \
+%endif
 %if !%{build_libjava}
         --disable-libgcj \
 %else
@@ -1481,9 +1423,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --enable-linker-build-id \
 %if 0%{?gcc_target_arch:1}
 %if 0%{?gcc_icecream:1}
-       --with-build-sysroot=/ \
-       --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
-       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
+       --with-sysroot=/ \
+       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/include/c++/%{gcc_dir_version} \
        --enable-linux-futex \
 %endif
 %if 0%{?canonical_target:1}
@@ -1519,9 +1460,10 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
 %endif
 %if "%{TARGET_ARCH}" == "armv7l" 
        --with-arch=armv7-a \
-       --with-tune=cortex-a9 \
-    --with-float=soft \
-       --with-fpu=vfpv3-d16 \
+       --with-tune=cortex-a8 \
+       --with-float=softfp \
+       --with-fpu=vfpv3 \
+       --with-mode=thumb \
        --disable-sjlj-exceptions \
 %endif
 %if  "%{TARGET_ARCH}" == "armv7hl"