reflect previous commit for setting gcc_dir_version to other spec files
[platform/upstream/gcc48.git] / packaging / gcc48-testresults.spec
index 44cfeca..2ea442c 100644 (file)
@@ -176,9 +176,7 @@ BuildRequires: gdb
 URL:          http://gcc.gnu.org/
 Version: 4.8.1
 Release:      1
-%define gcc_version %(echo %version | sed 's/_.*//')
-%define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
-%define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
+%define gcc_dir_version 4.8
 %define binsuffix -4.8
 
 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
@@ -206,7 +204,7 @@ Suggests: gcc48-info gcc48-locale
 %endif
 
 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
-Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
+Source:                gcc-%{version}.tar.bz2
 Source1:       change_spec
 Source3:       gcc48-rpmlintrc
 Source4:       ecj.jar
@@ -215,7 +213,6 @@ Source6:    baselibs.conf
 
 Summary:      Testsuite results
 License:       SUSE-Public-Domain
-Group:        Development/Languages/C and C++
 
 %description 
 Results from running the gcc and target library testsuites.
@@ -332,7 +329,7 @@ Results from running the gcc and target library testsuites.
 
 
 %prep
-%setup -q -n gcc-%{gcc_version}%{snapshot_date}
+%setup -q -n gcc-%{version}
 
 
 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
@@ -544,9 +541,9 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
 %endif
 %if "%{TARGET_ARCH}" == "armv7l" 
        --with-arch=armv7-a \
-       --with-tune=cortex-a9 \
-    --with-float=soft \
-       --with-fpu=vfpv3-d16 \
+       --with-tune=cortex-a8 \
+       --with-float=softfp \
+       --with-fpu=vfpv3 \
        --disable-sjlj-exceptions \
 %endif
 %if  "%{TARGET_ARCH}" == "armv7hl"