Fixed package groups
[platform/upstream/gcc48.git] / packaging / gcc47.spec
index 54757ca..de101aa 100644 (file)
@@ -294,7 +294,7 @@ Extensive HTML documentation for the GNU C++ standard library.
 %package -n libgcc47
 Summary:      C compiler runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libgcc%{libgcc_s} = %{version}-%{release}
 Conflicts: libgcc%{libgcc_s} < %{version}-%{release}
@@ -316,7 +316,7 @@ Libgcc is needed for dynamically linked C programs.
 %package -n libgcc47-32bit
 Summary:      C compiler runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libgcc%{libgcc_s}-32bit = %{version}-%{release}
 Conflicts: libgcc%{libgcc_s}-32bit < %{version}-%{release}
@@ -338,7 +338,7 @@ Libgcc is needed for dynamically linked C programs.
 %package -n libgcc47-64bit
 Summary:      C compiler runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libgcc%{libgcc_s}-64bit = %{version}-%{release}
 Conflicts: libgcc%{libgcc_s}-64bit < %{version}-%{release}
@@ -361,7 +361,7 @@ Libgcc is needed for dynamically linked C programs.
 %package -n libgomp47
 Summary:      The GNU compiler collection OpenMP runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libgomp1 = %{version}-%{release}
 Conflicts: libgomp1 < %{version}-%{release}
@@ -387,7 +387,7 @@ option.
 %package -n libgomp47-32bit
 Summary:      The GNU compiler collection OpenMP runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libgomp1-32bit = %{version}-%{release}
 Conflicts: libgomp1-32bit < %{version}-%{release}
@@ -413,7 +413,7 @@ option.
 %package -n libgomp47-64bit
 Summary:      The GNU compiler collection OpenMP runtime library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libgomp1-64bit = %{version}-%{release}
 Conflicts: libgomp1-64bit < %{version}-%{release}
@@ -440,7 +440,7 @@ option.
 %package -n libstdc++47
 Summary:      The standard C++ shared library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libstdc++6 = %{version}-%{release}
 Conflicts: libstdc++6 < %{version}-%{release}
@@ -463,7 +463,7 @@ The standard C++ library, needed for dynamically linked C++ programs.
 %package -n libstdc++47-32bit
 Summary:      The standard C++ shared library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libstdc++6-32bit = %{version}-%{release}
 Conflicts: libstdc++6-32bit < %{version}-%{release}
@@ -486,7 +486,7 @@ The standard C++ library, needed for dynamically linked C++ programs.
 %package -n libstdc++47-64bit
 Summary:      The standard C++ shared library
 License:        GPL-3.0-with-GCC-exception
-Group:        System/Libraries
+Group:        Base/Libraries
 %if 0%{!?build_optional_compiler:1}
 Provides: libstdc++6-64bit = %{version}-%{release}
 Conflicts: libstdc++6-64bit < %{version}-%{release}
@@ -1077,7 +1077,7 @@ Source code for this package is in gcc.
 %package -n gcc47-java
 Summary:      The GNU Java Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/Java
+Group:        Development/Languages
 Requires: gcc47 = %{version}
 Requires: libgcj47-devel = %{version}-%{release}
 
@@ -1088,7 +1088,7 @@ The Java compiler from the GCC-tools-suite.
 %package -n libgcj_bc47
 Summary:      Fake library for BC-ABI compatibility.
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
+Group:        Development/Libraries
 Provides: libgcj_bc1 = %{version}-%{release}
 Conflicts: libgcj_bc1 < %{version}-%{release}
 # libgcj_bc is special in that it just contains a symlink to
@@ -1121,7 +1121,7 @@ These are the jar files that go along with the gcj front end to gcc.
 %package -n libgcj47-devel
 Summary:      Include Files and Libraries mandatory for Development.
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
+Group:        Development/Libraries
 Requires: libstdc++47-devel = %{version}
 Requires: libgcj%{gcj_sover} >= %{version}-%{release}
 Requires: libgcj_bc1 >= %{version}-%{release}
@@ -1139,7 +1139,7 @@ to develop applications that require these.
 %package -n gcc47-gij
 Summary:      Java Bytecode Interpreter for gcc
 License:      GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
+Group:        Development/Libraries
 Requires: libgcj%{gcj_sover} >= %{version}-%{release}
 
 %description -n gcc47-gij
@@ -1151,7 +1151,7 @@ This package contains the java bytecode interpreter gij and related tools.
 %package -n libffi47
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Toolchain
+Group:        Base/Libraries
 Provides: g-wrap:/usr/lib/libffi.so.4
 Provides: libffi4 = %{version}-%{release}
 Conflicts: libffi4 < %{version}-%{release}
@@ -1170,7 +1170,7 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi47-32bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Toolchain
+Group:        Base/Libraries
 Provides: g-wrap:/usr/lib/libffi.so.4
 Provides: libffi4-32bit = %{version}-%{release}
 Conflicts: libffi4-32bit < %{version}-%{release}
@@ -1189,7 +1189,7 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi47-64bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Toolchain
+Group:        Base/Libraries
 Provides: g-wrap:/usr/lib/libffi.so.4
 Provides: libffi4-64bit = %{version}-%{release}
 Conflicts: libffi4-64bit < %{version}-%{release}