cleanup spec
[platform/upstream/gcc48.git] / packaging / gcc47.spec
index 19aad57..8124958 100644 (file)
@@ -9,16 +9,11 @@
 %define build_ada 0
 %endif
 
-%define quadmath_arch %ix86 x86_64 ia64
+%define quadmath_arch %ix86 x86_64 
 
 # We don't want to build java
-%ifarch mips
-%define build_java 0
-%define build_libjava 0
-%else
 %define build_java 1
 %define build_libjava 0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
-%endif
 
 %define build_cp 1
 %define build_fortran 1
@@ -72,9 +67,6 @@ BuildRequires: unzip
 %if 0%{?building_libffi:1}
 BuildRequires: pkg-config
 %endif
-%ifarch ia64
-BuildRequires: libunwind-devel
-%endif
 %if 0%{?run_tests:1}
 BuildRequires: dejagnu
 BuildRequires: expect
@@ -82,18 +74,8 @@ BuildRequires: gdb
 %endif
 
 # Define version number of libgcc_s
-%ifarch hppa
-%define libgcc_s 4
-%else
 %define libgcc_s 1
-%endif
-%ifarch ppc
-# We support building the nof libraries, but don't want this in the
-# regular rpms
 %define build_nof 0
-%else
-%define build_nof 0
-%endif
 
 %define separate_bi32 0
 %define separate_bi64 0
@@ -257,9 +239,6 @@ Requires: libstdc++6 >= %{version}-%{release}
 Requires: libstdc++47 = %{version}-%{release}
 %endif
 Requires: glibc-devel
-%ifarch ia64
-Requires: libunwind-devel
-%endif
 
 %description -n libstdc++47-devel
 This package contains all the headers and libraries of the standard C++
@@ -277,9 +256,6 @@ Requires: libstdc++6-32bit >= %{version}-%{release}
 Requires: libstdc++47-32bit = %{version}-%{release}
 %endif
 Requires: glibc-devel-32bit
-%ifarch ia64
-Requires: libunwind-devel
-%endif
 
 %description -n libstdc++47-devel-32bit
 This package contains all the headers and libraries of the standard C++
@@ -297,9 +273,6 @@ Requires: libstdc++6-64bit >= %{version}-%{release}
 Requires: libstdc++47-64bit = %{version}-%{release}
 %endif
 Requires: glibc-devel-64bit
-%ifarch ia64
-Requires: libunwind-devel
-%endif
 
 %description -n libstdc++47-devel-64bit
 This package contains all the headers and libraries of the standard C++
@@ -1157,9 +1130,6 @@ Requires: gtk2-devel
 Requires: libart_lgpl-devel
 Requires: glibc-devel
 Requires: zlib-devel
-%ifarch ia64
-Requires: libunwind-devel
-%endif
 
 %description -n libgcj47-devel
 This package contains all necessary include files and libraries needed
@@ -1277,7 +1247,7 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n gcc47-testresults
 # GCC-TESTSUITE-DELETE-END
 Summary:      Testsuite results
-License:       SUSE-Public-Domain
+License:       Public-Domain
 Group:        Development/Languages/C and C++
 
 %description -n gcc47-testresults
@@ -1618,12 +1588,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
 %else
        --program-suffix=%{binsuffix} \
        --enable-linux-futex \
-%ifarch ia64
-       --with-system-libunwind \
-%else
        --without-system-libunwind \
 %endif
-%endif
 %if "%{TARGET_ARCH}" == "armv5tel"
        --with-arch=armv5te \
        --with-float=soft \
@@ -1664,7 +1630,7 @@ make stage1-bubble $PARALLEL
 make all-target-libffi $PARALLEL
 %else
 # Only run profiled bootstrap on archs where it works
-#%ifarch %ix86 x86_64 ppc ppc64 ia64
+#%ifarch %ix86 x86_64 
 #make profiledbootstrap-lean STAGE1_CFLAGS="-O -g" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
 #%else
 %ifarch %arm
@@ -2041,9 +2007,6 @@ crt32_list=$RPM_BUILD_ROOT%{versmainlibdirbi32}/crt*.o
 crt64_list=$RPM_BUILD_ROOT%{versmainlibdirbi64}/crt*.o
 %endif
 %endif
-for o in $crt_list $crt32_list $crt64_list; do
-  objcopy -R ".comment.SUSE.OPTs" $o
-done
 %endif
 
 %if 0%{?building_libjava:1}
@@ -2482,26 +2445,7 @@ cd ..
 
 %files info
 %defattr(-,root,root)
-%doc %{_infodir}/cpp%{binsuffix}.info*.gz
-%doc %{_infodir}/cppinternals%{binsuffix}.info*.gz
-%doc %{_infodir}/gcc%{binsuffix}.info*.gz
-%doc %{_infodir}/gccint%{binsuffix}.info*.gz
-%doc %{_infodir}/gccinstall%{binsuffix}.info*.gz
-%doc %{_infodir}/libgomp%{binsuffix}.info*.gz
-%if %{build_fortran}
-%doc %{_infodir}/gfortran%{binsuffix}.info*.gz
-%ifarch %quadmath_arch
-%doc %{_infodir}/libquadmath%{binsuffix}.info*.gz
-%endif
-%endif
-%if %{build_java}
-%doc %{_infodir}/gcj%{binsuffix}.info*.gz
-%endif
-%if %{build_ada}
-%doc %{_infodir}/gnat-style%{binsuffix}.info*gz
-%doc %{_infodir}/gnat_rm%{binsuffix}.info*gz
-%doc %{_infodir}/gnat_ugn%{binsuffix}.info*gz
-%endif
+%doc %{_infodir}/*%{binsuffix}.info*.gz
 
 %files -n cpp47
 %defattr(-,root,root)