packaging: Enforce fpu for armv7hl build
[platform/upstream/linaro-gcc.git] / packaging / gcc-armv7l.spec
index a01cf67..2b6768a 100644 (file)
@@ -766,6 +766,11 @@ fi
 %undefine gcc_profiledbootstrap
 %endif
 
+%ifarch armv7hl
+# Required for correct libgcc and crt* build
+RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mfpu=neon"
+%endif
+
 %{!?gcc_skip_configure:
 %{?gcc_dump_configure:patch_configure.pl ..}   # Add debug prints into configure
 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
@@ -807,6 +812,7 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
 %ifarch armv7hl
        --with-arch=armv7-a \
        --with-tune=cortex-a8 \
+       --with-fpu=neon \
        --disable-sjlj-exceptions \
        --with-float=hard \
 %endif
@@ -835,6 +841,7 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
 %{?armv7hl: \
        --with-arch=armv7-a \
        --with-tune=cortex-a8 \
+       --with-fpu=neon \
        --disable-sjlj-exceptions \
        --with-float=hard \
 } \