Basing on 6.3.1 branch
[platform/upstream/gcc.git] / packaging / gcc-aarch64.spec
index c6af739..3789d9f 100644 (file)
@@ -75,7 +75,7 @@ BuildRequires: expect
 BuildRequires: gdb
 %endif
 URL:           http://gcc.gnu.org/
-Version:       6.2.1
+Version:       6.3.1
 Release:       0
 Source:        gcc-%{version}.tar.bz2
 Source10: gmp-6.1.1.tar.bz2
@@ -750,6 +750,14 @@ UBSan runtime environment
 %post -n ubsan-runtime-env
 echo "print_cmdline=true:log_path=/tmp/ubsan.log" > /UBSAN_OPTIONS
 
+%package plugin-devel
+Summary:       GNU GCC Plugin development files
+License:       GPL-3.0+
+Group:         Development/Languages
+%description plugin-devel
+This package contains GCC Plugin development files needed for compiler
+plugins build.
+
 %package -n sanitizer-sources
 Summary:    Sanitizer family tools sources
 License:       MIT
@@ -807,7 +815,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
        --disable-libssp \
        --disable-bootstrap \
        --disable-libvtv \
-       --disable-plugin \
+       --enable-plugin \
+       --disable-libcc1 \
        --disable-libgcj \
        --with-slibdir=%{libdir} \
        --with-system-zlib \
@@ -1092,6 +1101,10 @@ install -m 0755 %{SOURCE23} %{buildroot}/%{_rpmconfigdir}/tizen/
 %{libsubdir}/cc1
 /lib/cpp
 
+%files plugin-devel
+%defattr(-,root,root)
+%{libsubdir}/plugin/*
+
 %{?gcc_run_tests:
 %files testresults
 %defattr(-,root,root)