Basing on 6.3.1 branch
[platform/upstream/gcc.git] / packaging / gcc-aarch64.spec
index 82233dd..3789d9f 100644 (file)
@@ -27,7 +27,7 @@
 %define asan_arch x86_64 %ix86 ppc ppc64 %sparc %arm aarch64
 %define itm_arch x86_64 %ix86 %arm ppc ppc64 ppc64le s390 s390x %sparc aarch64
 %define atomic_arch x86_64 %ix86 %arm aarch64 ppc ppc64 ppc64le s390 s390x %sparc m68k
-%define lsan_arch x86_64 aarch64 %arm %ix86
+%define lsan_arch x86_64 aarch64
 %define ubsan_arch x86_64 %ix86 ppc ppc64 %arm aarch64
 %define cilkrts_arch x86_64 %ix86
 
@@ -75,7 +75,7 @@ BuildRequires: expect
 BuildRequires: gdb
 %endif
 URL:           http://gcc.gnu.org/
-Version:       6.2.1
+Version:       6.3.1
 Release:       0
 Source:        gcc-%{version}.tar.bz2
 Source10: gmp-6.1.1.tar.bz2
@@ -530,16 +530,6 @@ The runtime library needed to run programs compiled with the
 %post -n libcilkrts-32bit -p /sbin/ldconfig
 %postun -n libcilkrts-32bit -p /sbin/ldconfig
 
-%package -n liblsan-32bit
-Summary:       The GNU Compiler Leak Sanitizer Runtime Library
-License:       MIT
-Group:         Development/Languages
-%description -n liblsan-32bit
-The runtime library needed to run programs compiled with the
--fsanitize=leak option of the GNU Compiler Collection (GCC).
-%post -n liblsan-32bit -p /sbin/ldconfig
-%postun -n liblsan-32bit -p /sbin/ldconfig
-
 %package -n libubsan-32bit
 Summary:       The GNU Compiler Undefined Sanitizer Runtime Library
 License:       MIT
@@ -825,7 +815,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
        --disable-libssp \
        --disable-bootstrap \
        --disable-libvtv \
-       --disable-plugin \
+       --enable-plugin \
+       --disable-libcc1 \
        --disable-libgcj \
        --with-slibdir=%{libdir} \
        --with-system-zlib \
@@ -1137,13 +1128,6 @@ install -m 0755 %{SOURCE23} %{buildroot}/%{_rpmconfigdir}/tizen/
 %{libsubdir}/32/libasan.so.*
 %endif
 
-%ifarch %lsan_arch
-%files -n liblsan-32bit
-%manifest gcc.manifest
-%defattr(-,root,root)
-%{libsubdir}/32/liblsan.so.*
-%endif
-
 %ifarch %atomic_arch
 %files -n libatomic-32bit
 %manifest gcc.manifest