fix build break caused by changing upgrade script name
[platform/upstream/fontconfig.git] / packaging / fontconfig.spec
index 1511de7..bda5710 100644 (file)
@@ -71,7 +71,7 @@ make %{?jobs:-j%jobs}
 %install
 rm -rf %{buildroot}
 mkdir -p %{buildroot}%{upgrade_script_path}
-cp -f scripts/fontconfig_upgrade.sh %{buildroot}%{upgrade_script_path}
+cp -f scripts/500.fontconfig.sh %{buildroot}%{upgrade_script_path}
 
 %make_install
 
@@ -98,6 +98,12 @@ mkdir -p %{TZ_SYS_RO_SHARE}/fonts
 mkdir -p %{TZ_SYS_RO_SHARE}/fallback_fonts
 mkdir -p %{TZ_SYS_RO_SHARE}/app_fonts
 
+mkdir -p %{TZ_SYS_VAR}/cache/fontconfig
+chown root:root %{TZ_SYS_VAR}/cache/fontconfig
+chmod 755 %{TZ_SYS_VAR}/cache/fontconfig
+chsmack -t %{TZ_SYS_VAR}/cache/fontconfig
+chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig
+
 # Skip making fontconfig cache folder for users. (/opt/home/app/.cache)
 # The path will be changed according to a name of user.
 #rm -rf %{TZ_USER_CACHE}/fontconfig
@@ -118,12 +124,9 @@ mkdir -p %{TZ_SYS_RO_SHARE}/app_fonts
 # The check for existance is needed on dual-arch installs (the second
 #  copy of fontconfig might install the binary instead of the first)
 # The HOME setting is to avoid problems if HOME hasn't been reset
-if [ -x %{TZ_SYS_BIN}/fc-cache ] && %{TZ_SYS_BIN}/fc-cache --version 2>&1 | grep -q %{version} ; then
-fc-cache -rf --system-only
-chsmack -t %{TZ_SYS_VAR}/cache/fontconfig
-chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig
-chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig/*
-fi
+#if [ -x %{TZ_SYS_BIN}/fc-cache ] && %{TZ_SYS_BIN}/fc-cache --version 2>&1 | grep -q %{version} ; then
+#fc-cache -rf --system-only
+#fi
 
 %postun -p /sbin/ldconfig
 
@@ -142,7 +145,7 @@ fi
 %config(noreplace) %{TZ_SYS_RO_ETC}/fonts/conf.d/*.conf
 %{TZ_SYS_RO_SHARE}/license/%{name}
 %{_tmpfilesdir}/fontconfig.conf
-%{upgrade_script_path}/fontconfig_upgrade.sh
+%{upgrade_script_path}/500.fontconfig.sh
 
 %files devel
 %manifest fontconfig.manifest