upgrade to 2.14.2
[platform/upstream/fontconfig.git] / packaging / fontconfig.spec
index bdac6a0..ab5e359 100644 (file)
@@ -1,8 +1,8 @@
-%global freetype_version 2.5.0
+%global freetype_version 2.9.0
 
 Name:           fontconfig
 Summary:        Font configuration and customization library
-Version:        2.11.93
+Version:        2.14.2
 Release:        1
 Group:          Graphics & UI Framework/Fonts
 License:        MIT
@@ -15,12 +15,15 @@ BuildRequires:  gawk
 BuildRequires:  expat-devel
 BuildRequires:  perl
 BuildRequires:  gperf
-BuildRequires:  python
+BuildRequires:  python3
 BuildRequires:  systemd-devel
+BuildRequires:  gettext-tools
+BuildRequires:  libuuid-devel
 BuildRequires:  pkgconfig(libtzplatform-config)
 Requires(pre):  %{TZ_SYS_BIN}/fc-cache, %{TZ_SYS_BIN}/mkdir %{TZ_SYS_BIN}/rm, %{TZ_SYS_BIN}/grep, %{TZ_SYS_BIN}/chsmack
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
+Requires: security-config
 
 %description
 Fontconfig is designed to locate fonts within the
@@ -55,7 +58,7 @@ export HASDOCBOOK=no
     --with-expat-include=%{_includedir} \
     --with-expat-lib=%{_libdir} \
     --with-freetype-config=%{TZ_SYS_BIN}/freetype-config \
-    --with-add-fonts=%{TZ_SYS_RO_SHARE}/fonts,%{TZ_SYS_RO_SHARE}/app_fonts,%{TZ_SYS_RO_SHARE}/fallback_fonts \
+    --with-add-fonts=%{TZ_SYS_RO_SHARE}/fonts,%{TZ_SYS_RO_SHARE}/app_fonts,%{TZ_SYS_RO_SHARE}/fallback_fonts,%{TZ_SYS_SHARE}/fonts \
     --with-cache-dir=%{TZ_SYS_VAR}/cache/fontconfig \
     --with-baseconfigdir=%{TZ_SYS_RO_ETC}/fonts \
     --with-configdir=%{TZ_SYS_RO_ETC}/fonts/conf.d \
@@ -78,8 +81,6 @@ install -m 0644 %SOURCE100 %{buildroot}%{_tmpfilesdir}/fontconfig.conf
 # and own /usr/share/fonts
 mydir=$RPM_BUILD_ROOT%{TZ_SYS_RO_SHARE}/fonts
 mkdir -p $RPM_BUILD_ROOT%{TZ_SYS_RO_SHARE}/fonts
-mkdir -p %{buildroot}%{TZ_SYS_RO_SHARE}/license
-cat COPYING > %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}
 
 # Remove unpackaged files. no need when configure --disable-static
 #rm $RPM_BUILD_ROOT%{_libdir}/*.la
@@ -91,8 +92,31 @@ cat COPYING > %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}
 umask 0022
 
 mkdir -p %{TZ_SYS_RO_SHARE}/fonts
+chmod 755 %{TZ_SYS_RO_SHARE}/fonts
+chsmack -t %{TZ_SYS_RO_SHARE}/fonts
+chsmack -a User::App::Shared %{TZ_SYS_RO_SHARE}/fonts
+
 mkdir -p %{TZ_SYS_RO_SHARE}/fallback_fonts
+chmod 755 %{TZ_SYS_RO_SHARE}/fallback_fonts
+chsmack -t %{TZ_SYS_RO_SHARE}/fallback_fonts
+chsmack -a User::App::Shared %{TZ_SYS_RO_SHARE}/fallback_fonts
+
 mkdir -p %{TZ_SYS_RO_SHARE}/app_fonts
+chmod 755 %{TZ_SYS_RO_SHARE}/app_fonts
+chsmack -t %{TZ_SYS_RO_SHARE}/app_fonts
+chsmack -a User::App::Shared %{TZ_SYS_RO_SHARE}/app_fonts
+
+mkdir -p %{TZ_SYS_VAR}/cache/fontconfig
+chown root:root %{TZ_SYS_VAR}/cache/fontconfig
+chmod 755 %{TZ_SYS_VAR}/cache/fontconfig
+chsmack -t %{TZ_SYS_VAR}/cache/fontconfig
+chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig
+
+mkdir -p %{TZ_SYS_SHARE}/fonts
+chown app_fw:users %{TZ_SYS_SHARE}/fonts
+chmod 755 %{TZ_SYS_SHARE}/fonts
+chsmack -t %{TZ_SYS_SHARE}/fonts
+chsmack -a User::App::Shared %{TZ_SYS_SHARE}/fonts
 
 # Skip making fontconfig cache folder for users. (/opt/home/app/.cache)
 # The path will be changed according to a name of user.
@@ -114,9 +138,9 @@ mkdir -p %{TZ_SYS_RO_SHARE}/app_fonts
 # The check for existance is needed on dual-arch installs (the second
 #  copy of fontconfig might install the binary instead of the first)
 # The HOME setting is to avoid problems if HOME hasn't been reset
-if [ -x %{TZ_SYS_BIN}/fc-cache ] && %{TZ_SYS_BIN}/fc-cache --version 2>&1 | grep -q %{version} ; then
-fc-cache -rf --system-only
-fi
+#if [ -x %{TZ_SYS_BIN}/fc-cache ] && %{TZ_SYS_BIN}/fc-cache --version 2>&1 | grep -q %{version} ; then
+#fc-cache -rf --system-only
+#fi
 
 %postun -p /sbin/ldconfig
 
@@ -130,11 +154,13 @@ fi
 %{TZ_SYS_RO_ETC}/fonts/*
 %dir %{TZ_SYS_RO_ETC}/fonts/conf.avail
 %dir %{TZ_SYS_RO_SHARE}/fonts
+%{TZ_SYS_RO_SHARE}/gettext/its/fontconfig*
+%{TZ_SYS_RO_SHARE}/locale/*/*/fontconfig*
 %doc %{TZ_SYS_RO_ETC}/fonts/conf.d/README
 %config %{TZ_SYS_RO_ETC}/fonts/conf.avail/*.conf
 %config(noreplace) %{TZ_SYS_RO_ETC}/fonts/conf.d/*.conf
-%{TZ_SYS_RO_SHARE}/license/%{name}
 %{_tmpfilesdir}/fontconfig.conf
+%license COPYING
 
 %files devel
 %manifest fontconfig.manifest