add Tizen tv profile only configuration
[platform/upstream/fontconfig.git] / packaging / fontconfig.spec
index 31c4dba..a2e5d1f 100644 (file)
@@ -23,6 +23,7 @@ BuildRequires:  pkgconfig(libtzplatform-config)
 Requires(pre):  %{TZ_SYS_BIN}/fc-cache, %{TZ_SYS_BIN}/mkdir %{TZ_SYS_BIN}/rm, %{TZ_SYS_BIN}/grep, %{TZ_SYS_BIN}/chsmack
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
+Requires: security-config
 
 %description
 Fontconfig is designed to locate fonts within the
@@ -52,6 +53,7 @@ cp %{SOURCE1001} .
 # We don't want to rebuild the docs, but we want to install the included ones.
 export HASDOCBOOK=no
 
+%if "%{?profile}" != "tv"
 %reconfigure --disable-static \
     --with-expat=%{_prefix} \
     --with-expat-include=%{_includedir} \
@@ -64,6 +66,20 @@ export HASDOCBOOK=no
     --with-templatedir=%{TZ_SYS_RO_ETC}/fonts/conf.avail \
     --with-xmldir=%{TZ_SYS_RO_ETC}/fonts \
     --disable-docs
+%else
+%reconfigure --disable-static \
+    --with-expat=%{_prefix} \
+    --with-expat-include=%{_includedir} \
+    --with-expat-lib=%{_libdir} \
+    --with-freetype-config=%{TZ_SYS_BIN}/freetype-config \
+    --with-add-fonts=%{TZ_SYS_RO_SHARE}/fonts \
+    --with-cache-dir=%{TZ_SYS_VAR}/cache/fontconfig \
+    --with-baseconfigdir=%{TZ_SYS_RO_ETC}/fonts \
+    --with-configdir=%{TZ_SYS_RO_ETC}/fonts/conf.d \
+    --with-templatedir=%{TZ_SYS_RO_ETC}/fonts/conf.avail \
+    --with-xmldir=%{TZ_SYS_RO_ETC}/fonts \
+    --disable-docs
+%endif
 
 make %{?jobs:-j%jobs}
 
@@ -91,17 +107,17 @@ mkdir -p $RPM_BUILD_ROOT%{TZ_SYS_RO_SHARE}/fonts
 umask 0022
 
 mkdir -p %{TZ_SYS_RO_SHARE}/fonts
-chmod 444 %{TZ_SYS_RO_SHARE}/fonts
+chmod 755 %{TZ_SYS_RO_SHARE}/fonts
 chsmack -t %{TZ_SYS_RO_SHARE}/fonts
 chsmack -a User::App::Shared %{TZ_SYS_RO_SHARE}/fonts
 
 mkdir -p %{TZ_SYS_RO_SHARE}/fallback_fonts
-chmod 444 %{TZ_SYS_RO_SHARE}/fallback_fonts
+chmod 755 %{TZ_SYS_RO_SHARE}/fallback_fonts
 chsmack -t %{TZ_SYS_RO_SHARE}/fallback_fonts
 chsmack -a User::App::Shared %{TZ_SYS_RO_SHARE}/fallback_fonts
 
 mkdir -p %{TZ_SYS_RO_SHARE}/app_fonts
-chmod 444 %{TZ_SYS_RO_SHARE}/app_fonts
+chmod 755 %{TZ_SYS_RO_SHARE}/app_fonts
 chsmack -t %{TZ_SYS_RO_SHARE}/app_fonts
 chsmack -a User::App::Shared %{TZ_SYS_RO_SHARE}/app_fonts