fontconfig: fix smack issue from /opt/share/fonts, ~/.fonts/, ~/.fontconfig
[platform/upstream/fontconfig.git] / packaging / fontconfig.spec
index 13fba0a..7ab9ae2 100644 (file)
@@ -1,8 +1,8 @@
-%global freetype_version 2.5.0
+%global freetype_version 2.9.0
 
 Name:           fontconfig
 Summary:        Font configuration and customization library
-Version:        2.12.1
+Version:        2.13.0
 Release:        1
 Group:          Graphics & UI Framework/Fonts
 License:        MIT
@@ -17,6 +17,8 @@ BuildRequires:  perl
 BuildRequires:  gperf
 BuildRequires:  python
 BuildRequires:  systemd-devel
+BuildRequires:  gettext-tools
+BuildRequires:  libuuid-devel
 BuildRequires:  pkgconfig(libtzplatform-config)
 Requires(pre):  %{TZ_SYS_BIN}/fc-cache, %{TZ_SYS_BIN}/mkdir %{TZ_SYS_BIN}/rm, %{TZ_SYS_BIN}/grep, %{TZ_SYS_BIN}/chsmack
 Requires(post): /sbin/ldconfig
@@ -102,6 +104,12 @@ chmod 755 %{TZ_SYS_VAR}/cache/fontconfig
 chsmack -t %{TZ_SYS_VAR}/cache/fontconfig
 chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig
 
+mkdir -p %{TZ_SYS_SHARE}/fonts
+chown app_fw:users %{TZ_SYS_SHARE}/fonts
+chmod 755 %{TZ_SYS_SHARE}/fonts
+chsmack -t %{TZ_SYS_SHARE}/fonts
+chsmack -a User::App::Shared %{TZ_SYS_SHARE}/fonts
+
 # Skip making fontconfig cache folder for users. (/opt/home/app/.cache)
 # The path will be changed according to a name of user.
 #rm -rf %{TZ_USER_CACHE}/fontconfig
@@ -138,6 +146,8 @@ chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig
 %{TZ_SYS_RO_ETC}/fonts/*
 %dir %{TZ_SYS_RO_ETC}/fonts/conf.avail
 %dir %{TZ_SYS_RO_SHARE}/fonts
+%{TZ_SYS_RO_SHARE}/gettext/its/fontconfig*
+%{TZ_SYS_RO_SHARE}/locale/*/*/fontconfig*
 %doc %{TZ_SYS_RO_ETC}/fonts/conf.d/README
 %config %{TZ_SYS_RO_ETC}/fonts/conf.avail/*.conf
 %config(noreplace) %{TZ_SYS_RO_ETC}/fonts/conf.d/*.conf