Remove hardcoded path for multiuser support
[platform/upstream/filesystem.git] / packaging / filesystem.spec
index 8f14f71..a009790 100644 (file)
@@ -2,6 +2,7 @@
 %bcond_with x
 %define disable_docs_package 1
 %define debug_package %{nil}
+
 Name:           filesystem
 Version:        3.1
 Release:        0
@@ -9,6 +10,7 @@ License:        Public Domain
 Summary:        The basic directory layout for a Linux system
 Url:            https://fedorahosted.org/filesystem
 Group:          Base/Configuration
+BuildRequires:  pkgconfig(libtzplatform-config)
 Requires(pre): setup
 Source2:        languages
 Source3:        languages.man
@@ -51,12 +53,11 @@ mkdir -p boot dev \
        usr/share/{xsessions,X11} \
 %endif
        etc/{xdg/autostart,ld.so.conf.d,opt,pm/{config.d,power.d,sleep.d},xinetd.d,skel,sysconfig,pki} \
-       home media mnt opt/home/{app,developer} proc root run/lock srv sys tmp \
+        home media mnt proc root run/lock srv sys tmp \
         usr/{bin,etc,games,include,%{_lib}/{pkgconfig,games,sse2,tls,X11,pm-utils/{module.d,power.d,sleep.d}},lib/{games,locale,modules,sse2},libexec,local/{bin,etc,games,lib,%{_lib},sbin,src,share/{applications,man/man{1,2,3,4,5,6,7,8,9,n,1x,2x,3x,4x,5x,6x,7x,8x,9x},info},libexec,include,},sbin,share/{help/C,aclocal,applications,augeas/lenses,backgrounds,desktop-directories,dict,doc,empty,games,ghostscript/conf.d,gnome,icons,idl,info,man/man{1,2,3,4,5,6,7,8,9,n,1x,2x,3x,4x,5x,6x,7x,8x,9x,0p,1p,3p},mime-info,misc,omf,pixmaps,sounds,themes},src,src/kernels,src/debug} \
         var/{adm,empty,gopher,lib/{empty,games,misc,rpm-state},local,lock/subsys,log,nis,preserve,run,spool/{mail,lpd,uucp},tmp,db,cache,opt,games,yp} \
-        opt/{dbspace,usr/dbspace} \
-        opt/usr/{media,share} \
-        usr/apps
+        %{buildroot}%{TZ_SYS_DB} \
+        %{buildroot}%{TZ_SYS_RO_APP}
 
 ln -snf ../var/tmp usr/tmp
 ln -snf spool/mail var/mail
@@ -107,8 +108,6 @@ return 0
 %post -p <lua>
 posix.symlink("../run", "/var/run")
 posix.symlink("../run/lock", "/var/lock")
-posix.symlink("/opt/home/app", "/home/app")
-posix.symlink("/opt/home/developer", "/home/developer")
 
 %files -f filelist
 %manifest %{name}.manifest
@@ -123,8 +122,6 @@ posix.symlink("/opt/home/developer", "/home/developer")
 %endif
 %{_sysconfdir}/xdg
 %{_sysconfdir}/opt
-%attr(700,app,app) /opt/home/app
-%attr(700,developer,developer) /opt/home/developer
 %{_sysconfdir}/pm
 %{_sysconfdir}/xinetd.d
 %{_sysconfdir}/skel
@@ -137,12 +134,7 @@ posix.symlink("/opt/home/developer", "/home/developer")
 #%endif
 /media
 %dir /mnt
-%dir /opt
-%dir %attr(755,root,root) /opt/dbspace
-%dir %attr(755,root,root) /opt/usr
-%dir %attr(755,root,app) /opt/usr/dbspace
-%dir %attr(755,app,app) /opt/usr/media
-%dir %attr(755,app,app) /opt/usr/share
+%dir %attr(755,root,root) %{TZ_SYS_DB}
 %attr(555,root,root) /proc
 %attr(550,root,root) /root
 /run
@@ -151,7 +143,7 @@ posix.symlink("/opt/home/developer", "/home/developer")
 /sys
 %attr(1777,root,root) /tmp
 %dir /usr
-%attr(755,root,root) /usr/apps
+%attr(755,root,root) %{TZ_SYS_RO_APP}
 %attr(555,root,root) /usr/bin
 /usr/etc
 /usr/games