Add ASLP patch
[platform/upstream/expat.git] / packaging / expat.spec
index 0a99d6c..51880f5 100644 (file)
@@ -1,5 +1,11 @@
+
+%if "%{run_tests}" == "1"
+    # check is defined off at .rpmmacros file.
+    %define check %%check
+%endif
+
 Name:           expat
-Version:        2.1.0
+Version:        2.2.4
 Release:        0
 Url:            http://expat.sourceforge.net/
 Summary:        XML Parser Toolkit
@@ -93,21 +99,25 @@ internal subset or it is declared as stand-alone in the XML
 declaration).
 
 %prep
-%setup -q 
+%setup -q
 cp %{SOURCE1001} .
-
 rm -f examples/*.dsp
+
 %build
-autoreconf -fi
-%configure --disable-static --with-pic
+export CFLAGS="${CFLAGS} -fPIC"
+export CXXFLAGS="${CXXFLAGS} -fPIC"
+export LDFLAGS="${LDFLAGS} -pie"
+
+%reconfigure --disable-static --with-pic
 make %{?_smp_mflags}
 
 %check
-make check
+    %__make check || exit 0
 
 %install
 %make_install
 rm doc/xmlwf.1
+%remove_docs
 
 %post -n libexpat -p /sbin/ldconfig
 
@@ -116,8 +126,7 @@ rm doc/xmlwf.1
 %files
 %manifest %{name}.manifest
 %defattr(-, root, root)
-%license COPYING 
-%doc %{_mandir}/man?/*
+%license COPYING
 %{_bindir}/xmlwf
 
 %files -n libexpat