use Tizen project configuration, II
[platform/upstream/evolution-data-server.git] / packaging / evolution-data-server.spec
index 7439cc3..6b9aa98 100644 (file)
@@ -1,7 +1,8 @@
+%bcond_with introspection
+
 %define baseline 3.12
 
 %define USE_EVOLDAP 0
-%define with_introspection 1
 %define enable_goa no
 %define enable_uoa no
 %define enable_gtk no
@@ -29,6 +30,8 @@ Group:          Development/Libraries
 Url:            http://www.gnome.org
 Source0:        http://download.gnome.org/sources/evolution-data-server/%{baseline}/%{name}-%{version}.tar.xz
 Source98:       baselibs.conf
+Source1001:     evolution-data-server.manifest
+
 BuildRequires:  db4-devel
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
@@ -44,7 +47,9 @@ BuildRequires:  pkgconfig(gcr-base-3) >= 3.4
 %if %{?enable_goa} != no
 BuildRequires:  pkgconfig(goa-1.0) >= 3.2
 %endif
+%if %{with introspection}
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
+%endif
 %if %{?enable_gtk} != no
 BuildRequires:  pkgconfig(gtk+-3.0)
 %endif
@@ -120,7 +125,7 @@ and calendar in the GNOME Desktop.
 This package contains a shared system library to access address books.
 
 
-%if %{?with_introspection}
+%if %{with introspection}
 
 %package -n typelib-EBookContacts
 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
@@ -156,7 +161,7 @@ and calendar in the GNOME Desktop.
 This package contains a shared system library for address book backends.
 
 
-%if %{?with_introspection}
+%if %{with introspection}
 
 %package -n typelib-EBook
 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
@@ -193,7 +198,7 @@ and calendar in the GNOME Desktop.
 This package contains a shared system library.
 
 
-%if %{?with_introspection}
+%if %{with introspection}
 
 %package -n typelib-EDataServer
 Summary:        Evolution Data Server - Utilities Library, Introspection bindings
@@ -220,7 +225,7 @@ Requires:       libecal = %{version}
 Requires:       libedata-book = %{version}
 Requires:       libedata-cal = %{version}
 Requires:       libedataserver = %{version}
-%if %{?with_introspection}
+%if %{with introspection}
 Requires:       typelib-EBook = %{version}
 Requires:       typelib-EDataServer = %{version}
 %endif
@@ -247,6 +252,7 @@ This package contains developer documentation.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 
@@ -265,7 +271,7 @@ This package contains developer documentation.
  --enable-weather=%{?enable_weather} \
  --enable-gtk=%{?enable_gtk} \
  --enable-google=%{?enable_gdata} \
-%if %{?with_introspection}
+%if %{with introspection}
  --enable-vala-bindings \
  --enable-introspection \
 %else
@@ -327,6 +333,7 @@ mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
 
 %files
 %defattr(-,root,root)
+%manifest %{name}.manifest
 %license COPYING
 %{_datadir}/GConf/gsettings/evolution-data-server.convert
 %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
@@ -344,71 +351,83 @@ mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
 
 %files -n libcamel
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libcamel-1.2.so.%{so_camel}*
 
 
 %files -n libebackend
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libebackend-1.2.so.%{so_ebackend}*
 
 
 %files -n libebook
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libebook-1.2.so.%{so_ebook}*
 
 
-%if %{?with_introspection}
+%if %{with introspection}
 %files -n typelib-EBook
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/girepository-1.0/EBook-1.2.typelib
 %endif
 
 
 %files -n libebook-contacts
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libebook-contacts-1.2.so.0*
 
 
-%if %{?with_introspection}
+%if %{with introspection}
 %files -n typelib-EBookContacts
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/girepository-1.0/EBookContacts-1.2.typelib
 %endif
 
 
 %files -n libecal
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libecal-1.2.so.%{so_ecal}*
 
 
 %files -n libedata-book
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libedata-book-1.2.so.%{so_edata_book}*
 
 
 %files -n libedata-cal
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libedata-cal-1.2.so.%{so_edata_cal}*
 
 
 %files -n libedataserver
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/libedataserver-1.2.so.%{so_edataserver}*
 
 
-%if %{?with_introspection}
+%if %{with introspection}
 %files -n typelib-EDataServer
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_libdir}/girepository-1.0/EDataServer-1.2.typelib
 %endif
 
 
 %files devel
 %defattr(-, root, root)
+%manifest %{name}.manifest
 %{_includedir}/evolution-data-server/
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc
-%if %{?with_introspection}
+%if %{with introspection}
 %{_datadir}/gir-1.0/*.gir
 %dir %{_datadir}/vala
 %dir %{_datadir}/vala/vapi