add missing postun, pre, post for emgd-bin-x package
[profile/ivi/emgd-bin.git] / packaging / emgd-bin.spec
index ea82473..94bb27f 100644 (file)
@@ -221,8 +221,9 @@ rm -f /usr/lib/libEGL.so.1.1.*
 
 /sbin/ldconfig
 
-mkdir -p /usr/lib/systemd/system/sysinit.target.wants/
-pushd /usr/lib/systemd/system/sysinit.target.wants/
+%post x
+mkdir -p /usr/lib/systemd/system/multi-user.target.wants/
+pushd /usr/lib/systemd/system/multi-user.target.wants/
 ln -sf ../emgd-bin.service emgd-bin.service
 popd
 
@@ -233,18 +234,18 @@ fi
 
 %postun
 /sbin/ldconfig
-rm -f /usr/lib/systemd/system/sysinit.target.wants/emgd-bin.service
+
+%postun x
+rm -f /usr/lib/systemd/system/multi-user.target.wants/emgd-bin.service
 if [ -x /bin/systemctl ]; then
     systemctl daemon-reload >/dev/null 2>&1 || :
 fi
 
-
-%preun
+%preun x
 if [ -x /bin/systemctl ]; then
     sytemctl stop emgd-bin.service >/dev/null 2>&1 || :
 fi
 
-
 %files common
 %defattr(-,root,root,-)
 %{_docdir}/%{name}/license.txt