tizen 2.3.1 release
[framework/uifw/embryo.git] / packaging / embryo.spec
index c80caf7..d1e1178 100644 (file)
@@ -1,15 +1,14 @@
 Name:       embryo
 Summary:    A small virtual machine engine (in a library) and bytecode compiler
-Version:    1.0.999.svn60294
+Version:    1.6.0+svn.76491slp2+build07
 Release:    1
-Group:      TO_BE/FILLED_IN
-License:    TO BE FILLED IN
+Group:      System/Libraries
+License:    BSD 2-Clause
 URL:        http://www.enlightenment.org/
-Source0:    %{name}-%{version}.tar.bz2
+Source0:    %{name}-%{version}.tar.gz
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires: pkgconfig(eina)
-Provides: embryo-bin
 
 
 %description
@@ -18,31 +17,47 @@ Development files for libembryo0 Embryo is primarily a shared library that gives
  bytecode that it understands.  This abstract (or virtual) machine is
  similar to a real machine with a CPU, but it is emulated in
  software.
- .
  This packages contains headers and static libraries for Embryo.
 
 
-
 %package devel
 Summary:    A small virtual machine engine and bytecode compile (devel)
 Group:      Development/Libraries
 Requires:   %{name} = %{version}-%{release}
 
+
 %description devel
 A small virtual machine engine (in a library) and bytecode compile (devel)
 
+
+%package tools
+Summary:    A small virtual machine engine and bytecode compile (tools)
+Group:      Development/Tools
+Requires:   %{name} = %{version}-%{release}
+Provides:   %{name}-bin
+Obsoletes:  %{name}-bin
+
+
+%description tools
+A small virtual machine engine (in a library) and bytecode compile (tools)
+
+
 %prep
 %setup -q
 
 
 %build
+export CFLAGS+=" -fvisibility=hidden -fPIC -Wall"
+export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
 
 %autogen --disable-static
-%configure --disable-static
 make %{?jobs:-j%jobs}
 
 %install
 %make_install
+mkdir -p %{buildroot}/%{_datadir}/license
+cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{_datadir}/license/%{name}
+cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{_datadir}/license/%{name}-tools
 
 %post -p /sbin/ldconfig
 
@@ -51,8 +66,8 @@ make %{?jobs:-j%jobs}
 %files
 %defattr(-,root,root,-)
 %{_libdir}/libembryo.so.*
-/usr/bin/embryo_cc
-/usr/share/embryo/include/default.inc
+%{_datadir}/license/%{name}
+%manifest %{name}.manifest
 
 
 %files devel
@@ -62,3 +77,8 @@ make %{?jobs:-j%jobs}
 %{_libdir}/pkgconfig/*.pc
 
 
+%files tools
+%defattr(-,root,root,-)
+%{_bindir}/embryo_cc
+%{_datadir}/license/%{name}-tools
+%{_datadir}/embryo/include/default.inc