resetting manifest requested domain to floor
[platform/upstream/elfutils.git] / packaging / elfutils.spec
index 54765ae..ec3d7e3 100644 (file)
@@ -1,19 +1,20 @@
+%define keepstatic 1
 Name:           elfutils
-Version:        0.153
+Version:        0.155
 Release:        0
 License:        GPL-2.0-with-osi-exception
 Summary:        Higher-level library to access ELF
 Url:            http://elfutils.fedorahosted.org
-Group:          System/Libraries
+Group:          Base/Tools
 Source:         elfutils-%{version}.tar.bz2
 Source2:        baselibs.conf
+Source1001:    elfutils.manifest
 BuildRequires:  automake
 BuildRequires:  bison
 BuildRequires:  bzip2-devel
 BuildRequires:  flex
 BuildRequires:  xz-devel
 BuildRequires:  zlib-devel
-BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
 This package provides a higher-level library to access ELF files. This
@@ -21,7 +22,7 @@ is a part of elfutils package.
 
 %package -n libasm
 Summary:        A collection of utilities and DSOs to handle compiled objects
-Group:          Development/Tools/Other
+Group:          Base/Libraries
 
 %description -n libasm
 Elfutils is a collection of utilities, including ld (a linker), nm (for
@@ -34,8 +35,8 @@ which implement DWARF, ELF, and machine-specific ELF handling.
 %package -n libasm-devel
 License:        GPL-2.0-with-osi-exception
 Summary:        A collection of utilities and DSOs to handle compiled objects
-Group:          Development/Tools/Other
-Requires:       glibc-devel,
+Group:          Development/Libraries
+Requires:       glibc-devel
 Requires:       libasm = %{version}
 
 %description -n libasm-devel
@@ -49,9 +50,7 @@ which implement DWARF, ELF, and machine-specific ELF handling.
 %package -n libebl
 License:        GPL-2.0-with-osi-exception
 Summary:        A collection of utilities and DSOs to handle compiled objects
-Group:          Development/Tools/Other
-Provides:       libebl = %{version}
-Obsoletes:      libebl < %{version}
+Group:          Base/Libraries
 
 %description -n libebl
 Elfutils is a collection of utilities, including ld (a linker), nm (for
@@ -64,8 +63,8 @@ which implement DWARF, ELF, and machine-specific ELF handling.
 %package -n libebl-devel
 License:        GPL-2.0-with-osi-exception
 Summary:        Include Files and Libraries mandatory for Development
-Group:          Development/Libraries/C and C++
-Requires:       glibc-devel,
+Group:          Development/Libraries
+Requires:       glibc-devel
 Requires:       libdw-devel = %{version}
 Requires:       libebl = %{version}
 
@@ -76,6 +75,7 @@ to develop applications that require these.
 %package -n libelf
 License:        GPL-2.0-with-osi-exception
 Summary:        Library to read and write ELF files
+Group:          Base/Libraries
 
 %description -n libelf
 This package provides a high-level library to read and write ELF files.
@@ -84,8 +84,8 @@ This is a part of elfutils package.
 %package -n libelf-devel
 License:        GPL-2.0-with-osi-exception
 Summary:        Include Files and Libraries mandatory for Development
-Group:          Development/Libraries/C and C++
-Requires:       glibc-devel,
+Group:          Development/Libraries
+Requires:       glibc-devel
 Requires:       libelf = %{version}
 Conflicts:      libelf0-devel
 
@@ -96,6 +96,7 @@ to develop applications that require these.
 %package -n libdw
 License:        GPL-2.0-with-osi-exception
 Summary:        Library to access DWARF debugging information
+Group:          Base/Libraries
 
 %description -n libdw
 This package provides a high-level library to access the DWARF debugging
@@ -104,8 +105,8 @@ information.  This is a part of elfutils package.
 %package -n libdw-devel
 License:        GPL-2.0-with-osi-exception
 Summary:        Include Files and Libraries mandatory for Development
-Group:          Development/Libraries/C and C++
-Requires:       glibc-devel,
+Group:          Development/Libraries
+Requires:       glibc-devel
 Requires:       libdw = %{version}
 Requires:       libelf-devel = %{version}
 
@@ -115,14 +116,15 @@ to develop applications that require these.
 
 %prep
 %setup -q -n elfutils-%{version}
+cp %{SOURCE1001} .
 
 %build
-modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
-DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
-TIME="\"$(date -d "${modified}" "+%%R")\""
-find . -type f -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
+#modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
+#DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
+#TIME="\"$(date -d "${modified}" "+%%R")\""
+#find . -type f -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
 autoreconf -fi
-%configure --program-prefix=eu-
+%configure --program-prefix=eu- --disable-werror
 make %{?_smp_mflags}
 
 %install
@@ -143,15 +145,19 @@ ls -lR %{buildroot}%{_libdir}/libelf*
 %postun -n libdw -p /sbin/ldconfig
 
 %files
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_bindir}/*
 
 %files -n libasm
+%manifest %{name}.manifest
 %defattr(-,root,root)
+%license COPYING
 %{_libdir}/libasm.so.*
 %{_libdir}/libasm-%{version}.so
 
 %files -n libasm-devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_libdir}/libasm.so
 %{_libdir}/libasm.a
@@ -159,21 +165,27 @@ ls -lR %{buildroot}%{_libdir}/libelf*
 %{_includedir}/elfutils/libasm.h
 
 %files -n libebl
+%manifest %{name}.manifest
 %defattr(-,root,root)
+%license COPYING
 %{_libdir}/elfutils
 
 %files -n libebl-devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_libdir}/libebl.a
 %dir %{_includedir}/elfutils
 %{_includedir}/elfutils/libebl.h
 
 %files -n libelf
+%manifest %{name}.manifest
 %defattr(-,root,root)
+%license COPYING
 %{_libdir}/libelf.so.*
 %{_libdir}/libelf-%{version}.so
 
 %files -n libelf-devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_libdir}/libelf.so
 %{_libdir}/libelf.a
@@ -186,11 +198,14 @@ ls -lR %{buildroot}%{_libdir}/libelf*
 %{_includedir}/elfutils/version.h
 
 %files -n libdw
+%manifest %{name}.manifest
 %defattr(-,root,root)
+%license COPYING
 %{_libdir}/libdw.so.*
 %{_libdir}/libdw-%{version}.so
 
 %files -n libdw-devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_libdir}/libdw.a
 %{_libdir}/libdw.so