Packaging: update version to 0.1.11
[platform/core/uifw/e-mod-tizen-effect.git] / packaging / e-mod-tizen-effect.spec
index 231bc33..a0dfc11 100644 (file)
@@ -1,7 +1,5 @@
-%bcond_with x
-
 Name: e-mod-tizen-effect
-Version: 0.0.2
+Version: 0.1.11
 Release: 1
 Summary: The effect module for the enlightenment
 URL: http://www.enlightenment.org
@@ -14,10 +12,11 @@ BuildRequires: pkgconfig(ecore)
 BuildRequires: pkgconfig(edje)
 BuildRequires:  gettext
 BuildRequires:  edje-tools
+BuildRequires:  pkgconfig(wayland-server)
+BuildRequires:  pkgconfig(tizen-extension-server)
+BuildRequires: pkgconfig(wayland-tbm-server)
 
-%if !%{with x}
-ExclusiveArch:
-%endif
+%global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
 
 %description
 This package provides various window effect(animation)
@@ -29,19 +28,19 @@ as one module of enlightenment.
 %build
 
 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
-export CFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS}"
+export CFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} -DE_LOGGING=1"
 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
 
 %autogen
-%configure --prefix=/usr
+%configure --prefix=%{_prefix}
 make
 
 %install
 rm -rf %{buildroot}
 
 # for license notification
-mkdir -p %{buildroot}/usr/share/license
-cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
+mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
+cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
 
 # install
 make install DESTDIR=%{buildroot}
@@ -54,5 +53,5 @@ find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
 %defattr(-,root,root,-)
 %{_libdir}/enlightenment/modules/e-mod-tizen-effect
 %{_datadir}/enlightenment/data/themes
-/usr/share/license/%{name}
+%{TZ_SYS_RO_SHARE}/license/%{name}