Release a package
[profile/ivi/download-provider.git] / packaging / download-provider.spec
index df481f7..d46bb76 100644 (file)
@@ -1,7 +1,8 @@
+
 Name:       download-provider
 Summary:    download the contents in background.
-Version:       0.0.3
-Release:    2
+Version:       0.0.5
+Release:    8
 Group:      TO_BE/FILLED_IN
 License:    TO_BE/FILLED_IN
 Source0:    %{name}-%{version}.tar.gz
@@ -79,6 +80,50 @@ fi
 %{_libdir}/pkgconfig/download-provider.pc
 
 %changelog
+* Thu Sep 06 2012 Kwangmin Bang <justine.bang@samsung.com>
+- start to download again even if already finished
+- change thread style
+- arrange the request priority
+- change data type
+- wait till getting the response from client
+
+* Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
+- fix timeout error
+
+* Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
+- free slot after getting event from url-download
+- fix INTEGER OVERFLOW
+
+* Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
+- initialize mutex for auto-redownloading
+- support Pause/Resume with new connection
+- fix the memory leak
+
+* Mon Aug 27 2012 Kwangmin Bang <justine.bang@samsung.com>
+- Change the ownership of downloaded file
+- Add detached option when pthread is created
+- fix the failure getting history info from database
+- fix first timeout takes a long time
+- fix wrong checking of network status
+- fix the crash by double free
+- divide log level
+- Resolve prevent defects for agent module
+- Resolve a bug to join domain in case of playready
+
+* Tue Aug 23 2012 Kwangmin Bang <justine.bang@samsung.com>
+- event thread does not deal in some state
+- fix the lockup by mutex and the crash by invaild socket event
+
+* Tue Aug 22 2012 Jungki Kwak <jungki.kwak@samsung.com>
+- Fix the crash when use notification
+- One thread model for socket
+- Fix the defects found by prevent tool
+- Remove mutex lock/unlock in case of invalid id
+- Support the status of download in case of getting new connection with requestid
+- Clear db and register notification when stopped the download
+- Update notification function
+- Enable to set the defined file name by user
+
 * Tue Aug 17 2012 Jungki Kwak <jungki.kwak@samsung.com>
 - Enable to use destination path
 - Add to handle invalid id