license: Add macro to copy license file
[platform/core/uifw/download-fonts-service.git] / packaging / download-fonts-service.spec
old mode 100755 (executable)
new mode 100644 (file)
index 68db2e0..e25270c
@@ -1,23 +1,25 @@
 Name: download-fonts-service
-Summary: Master Download fonts service.
-Version: 0.0.7
+Summary: Master Download fonts service
+Version: 1.0.0
 Release: 1
-Group: TO_BE / FILLED_IN
+Group: Base/Package Management
 License: Apache-2.0
 Source0: %{name}-%{version}.tar.gz
+Source1001: download-fonts-service.manifest
 BuildRequires: cmake, gettext-tools, smack, coreutils
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(fontconfig)
 BuildRequires: pkgconfig(capi-system-system-settings)
 BuildRequires: pkgconfig(elementary)
 BuildRequires: pkgconfig(pkgmgr-info)
-BuildRequires: pkgconfig(security-server)
+BuildRequires: pkgconfig(pkgmgr-installer)
 
 %description
 Master Download fonts service.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 %if 0%{?sec_build_binary_debug_enable}
@@ -30,7 +32,7 @@ export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
 %endif
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DPRODUCT=private
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
 
 CFLAGS="${CFLAGS} -Wall -Winline -Werror" LDFLAGS="${LDFLAGS}" make %{?jobs:-j%jobs}
 
@@ -38,9 +40,12 @@ CFLAGS="${CFLAGS} -Wall -Winline -Werror" LDFLAGS="${LDFLAGS}" make %{?jobs:-j%j
 rm -rf %{buildroot}
 %make_install
 
+mkdir -p %{buildroot}%{_tmpfilesdir}
+
 %files -n download-fonts-service
 %manifest download-fonts-service.manifest
 %defattr(-,root,root,-)
-%{_prefix}/etc/package-manager/parserlib/category/*
+%license LICENSE
+/etc/package-manager/parserlib/category/*
 
 # End of a file