Add define HOST_XXX to support pal.h
[platform/core/dotnet/launcher.git] / packaging / dotnet-launcher.spec
index 1aa0949..e17aa7d 100644 (file)
@@ -117,6 +117,23 @@ export CFLAGS+=" -DBIT64 -DHOST_64BIT "
 export CXXFLAGS+=" -DBIT64 -DHOST_64BIT "
 %endif
 
+# add define HOST_XXX to support pal.h becuase processor-specifc glue code is removed from latest code
+%ifarch %{arm}
+export CFLAGS+=" -DHOST_ARM "
+export CXXFLAGS+=" -DHOST_ARM "
+%endif
+%ifarch ARM64
+export CFLAGS+=" -DHOST_ARM64 "
+export CXXFLAGS+=" -DHOST_ARM64 "
+%endif
+%ifarch %{ix86}
+export CFLAGS+=" -DHOST_X86 "
+export CXXFLAGS+=" -DHOST_X86 "
+%endif
+%ifarch x86_64
+export CFLAGS+=" -DHOST_AMD64"
+export CXXFLAGS+=" -DHOST_AMD64 "
+%endif
 %ifarch riscv64
 export CFLAGS+=" -DHOST_RISCV64 "
 export CXXFLAGS+=" -DHOST_RISCV64 "