Reenable default base address for system dlls support
[platform/core/dotnet/launcher.git] / packaging / dotnet-launcher.spec
index 3277e7f..23772a2 100644 (file)
@@ -53,6 +53,9 @@ Requires(preun): /usr/bin/systemctl
 %define _install_mdplugin_dir /etc/package-manager/parserlib/metadata
 %define _native_lib_dir /usr/share/dotnet.tizen/lib
 %define _tac_dir /opt/usr/dotnet
+%define _system_base_addr_file /opt/usr/dotnet.system.base.addr
+
+%define _default_base_addr_start 0x3000000
 
 ExcludeArch: aarch64
 
@@ -113,9 +116,9 @@ cmake \
 %if 0%{?use_default_base_addr}
        -DUSE_DEFAULT_BASE_ADDR="" \
 %endif
-%if 0%{?default_base_nitool}
        -DUNIQUE_DEFAULT_BASE_ADDR_SUPPORT="" \
-%endif
+       -DSYSTEM_BASE_FILE=%{_system_base_addr_file} \
+       -DDEFAULT_BASE_ADDR_START=%{_default_base_addr_start} \
        NativeLauncher
 
 make %{?jobs:-j%jobs} VERBOSE=1
@@ -137,11 +140,7 @@ install -m 0644 %{name}.conf %{buildroot}/etc/tmpfiles.d/%{name}.conf
 %post
 mkdir -p /opt/etc/skel/.dotnet
 chsmack -t -a User::App::Shared /opt/etc/skel/.dotnet
-%if 0%{?default_base_nitool}
-%{_bindir}/nitool --gen-unique-baddr-system --dll %{_runtime_dir}/System.Private.CoreLib.dll
-%else
-%{_bindir}/nitool --dll %{_runtime_dir}/System.Private.CoreLib.dll
-%endif
+%{_bindir}/dotnettool --ni-dll %{_runtime_dir}/System.Private.CoreLib.dll
 
 %files
 %manifest dotnet-launcher.manifest
@@ -151,7 +150,7 @@ chsmack -t -a User::App::Shared /opt/etc/skel/.dotnet
 %{_native_lib_dir}/libsqlite3.so
 %{_bindir}/nitool
 %{_bindir}/tpatool
-%{_bindir}/tactool
+%{_bindir}/dotnettool
 %{_install_mdplugin_dir}/libprefer_nuget_cache_plugin.so
 %{_install_mdplugin_dir}/libprefer_dotnet_aot_plugin.so
 %{_bindir}/dotnet-launcher
@@ -167,6 +166,7 @@ chsmack -t -a User::App::Shared /opt/etc/skel/.dotnet
 %manifest dotnet-launcher.manifest
 %defattr(-,root,root,-)
 %{_includedir}/ni_common.h
+%{_includedir}/tac_common.h
 %{_includedir}/dotnet_launcher_plugin.h
 %{_includedir}/coreclr_host.h
 %{_libdir}/libdotnet_launcher_util.so