Add crossgen2.tar.gz file and remove circular dependency issue
[platform/core/dotnet/build-tools.git] / packaging / dotnet-build-tools.spec
index 91f9105..253fd23 100644 (file)
@@ -12,15 +12,16 @@ Source0:    %{name}-%{version}.tar.gz
 Source1:    macros.dotnet-build-tools
 Source21:   dotnet-sdk-%{version}-linux-x64.tar.gz
 Source22:   deps.tar.gz
+Source23:   crossgen2.tar.gz
 
 AutoReqProv: no
 
 BuildRequires: patchelf
-BuildRequires: mscorlib
-BuildRequires: corefx-managed
-BuildRequires: csapi-tizenfx-full
-BuildRequires: crossgen2-mic
+#BuildRequires: crossgen2-mic
 
+Requires: mscorlib
+Requires: corefx-managed
+Requires: csapi-tizenfx-full
 Requires: corefx-managed-ref
 Requires: libicu
 Requires: openssl1.1
@@ -40,10 +41,8 @@ mkdir -p dotnet/deps
 mkdir -p dotnet/crossgen2/ref
 tar xvfz %{SOURCE21} -C dotnet
 tar xvfz %{SOURCE22} -C dotnet/deps
-
-cp -rf /opt/usr/dotnet/mic/* dotnet/crossgen2
-cp -rf /usr/share/dotnet.tizen/netcoreapp/*.dll dotnet/crossgen2/ref
-cp -rf /usr/share/dotnet.tizen/framework/*.dll dotnet/crossgen2/ref
+tar xvfz %{SOURCE23} -C dotnet/crossgen2
+#cp -rf /opt/usr/dotnet/mic/* dotnet/crossgen2
 
 %build
 # Prepare dotnet-sdk