Re-ordered build binary
[platform/upstream/docker-engine.git] / packaging / docker-engine.spec
index 5a1a4fc..8db2d17 100755 (executable)
@@ -23,8 +23,6 @@ Source15: runc.tar.bz2
 BuildRequires: git
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
-Requires: docker-containerd
-Requires: docker-runc 
 
 
 %description
@@ -88,19 +86,17 @@ cd ../../
 
 
 %build
-cd .%docker_path/engine
+cd .%docker_path/
 export GOROOT=%{_builddir}/%{name}-%{version}/go
 export PATH=$PATH:%{_builddir}/%{name}-%{version}/go/bin
 export GOPATH=%{_builddir}/%{name}-%{version}
 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper'
+export CGO_ENABLED=1
 
 go env
-echo 'docker daemon'
-export CGO_ENABLED=1
-AUTO_GOPATH=1 ./hack/make.sh dynbinary
 
 echo 'docker cli'
-cd ../cli
+cd ./cli
 make binary
 
 export BUILDTAGS=no_btrfs
@@ -112,6 +108,10 @@ echo 'runc build'
 cd ../../opencontainers/runc
 make all BUILDTAGS=""
 
+echo 'docker daemon'
+cd ../../docker/engine
+AUTO_GOPATH=1 ./hack/make.sh dynbinary
+
 %install
 rm -rf %{buildroot}
 # install binary