Remove unnecessary buildrequires
[platform/upstream/docker-engine.git] / packaging / docker-engine.spec
index 8db2d17..7ba59c8 100755 (executable)
@@ -20,7 +20,6 @@ Source13: docker-ce.tar.bz2
 Source14: containerd.tar.bz2
 Source15: runc.tar.bz2
 
-BuildRequires: git
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
@@ -86,17 +85,21 @@ cd ../../
 
 
 %build
-cd .%docker_path/
+cd .%docker_path/engine
 export GOROOT=%{_builddir}/%{name}-%{version}/go
 export PATH=$PATH:%{_builddir}/%{name}-%{version}/go/bin
 export GOPATH=%{_builddir}/%{name}-%{version}
 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper'
-export CGO_ENABLED=1
 
 go env
+echo "skip docker daemon build"
+echo "will be used from docker-ec build result"
+###echo 'docker daemon'
+###export CGO_ENABLED=1
+###AUTO_GOPATH=1 ./hack/make.sh dynbinary
 
 echo 'docker cli'
-cd ./cli
+cd ../cli
 make binary
 
 export BUILDTAGS=no_btrfs
@@ -108,10 +111,6 @@ echo 'runc build'
 cd ../../opencontainers/runc
 make all BUILDTAGS=""
 
-echo 'docker daemon'
-cd ../../docker/engine
-AUTO_GOPATH=1 ./hack/make.sh dynbinary
-
 %install
 rm -rf %{buildroot}
 # install binary