Apply rpm macro of hal install path
[platform/adaptation/samsung_exynos/device-manager-plugin-artik.git] / packaging / device-manager-plugin-artik.spec
index 0ab0f8d..0a01822 100644 (file)
@@ -29,6 +29,8 @@ cp %{SOURCE1} .
 
 %build
 %cmake . -DENABLE_DLOG=on \
+       -DHAL_LIB_DIR=%{_hal_libdir} \
+       -DHAL_LICENSE_DIR=%{_hal_licensedir}
 
 make %{?jobs:-j%jobs}
 
@@ -43,6 +45,6 @@ make %{?jobs:-j%jobs}
 /sbin/ldconfig
 
 %files
-/hal/lib/*.so*
+%{_hal_libdir}/*.so*
 %manifest %{name}.manifest
-%license LICENSE
+%{_hal_licensedir}/%{name}/LICENSE