Change input driver for Cando 10.1 Multi panel to evdev-multitouch
[profile/ivi/device-config-touch.git] / packaging / device-config-touch.spec
index 4628479..5c4dda4 100644 (file)
@@ -5,6 +5,7 @@ Summary:        Device specific configurations for Touch
 Group:          System/Hardware
 License:        GPLv2+
 Source0:       %{name}-%{version}.tar.bz2
+Source1001: packaging/device-config-touch.manifest 
 # >> gbp-patch-tags         # auto-added by gbp
 # << gbp-patch-tags         # auto-added by gbp
 BuildArch: noarch
@@ -26,35 +27,45 @@ Touch configuration files for %1.\
 # >> gbp-apply-patches    # auto-added by gbp
 # << gbp-apply-patches    # auto-added by gbp
 %build
+cp %{SOURCE1001} .
 
 %install
 
-mkdir -p %{buildroot}/opt/etc/X11/xorg.conf.d
-for f in `ls -1`; do
-       install -m 0644 $f %{buildroot}/opt/etc/X11/xorg.conf.d/
-done
+mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d
+install -m 0644 *.conf %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
 
 %touch_package cando
 %files cando
-/opt/etc/X11/xorg.conf.d/60-cando-mtev.conf
+%{_sysconfdir}/X11/xorg.conf.d/60-cando-evdevmultitouch.conf
+%manifest device-config-touch.manifest
 
 %touch_package mxt224
 %files mxt224
-/opt/etc/X11/xorg.conf.d/60-mxt224-mtev.conf
+%{_sysconfdir}/X11/xorg.conf.d/60-mxt224-evdevmultitouch.conf
+%manifest device-config-touch.manifest
+
+%touch_package Atmel
+%files Atmel
+%manifest device-config-touch.manifest
+%{_sysconfdir}/X11/xorg.conf.d/65-Atmel-mtev.conf
 
 %touch_package sitronix
 %files sitronix
-/opt/etc/X11/xorg.conf.d/70-sitronix-mtev.conf
+%{_sysconfdir}/X11/xorg.conf.d/70-sitronix-mtev.conf
+%manifest device-config-touch.manifest
 
 %touch_package Hanvon
 %files Hanvon
-/opt/etc/X11/xorg.conf.d/80-Hanvon-mtev.conf
+%{_sysconfdir}/X11/xorg.conf.d/80-Hanvon-mtev.conf
+%manifest device-config-touch.manifest
 
 %touch_package ILI
 %files ILI
-/opt/etc/X11/xorg.conf.d/90-ILI-mtev.conf
+%{_sysconfdir}/X11/xorg.conf.d/90-ILI-mtev.conf
+%manifest device-config-touch.manifest
 
 %touch_package eGalax
 %files eGalax
-/opt/etc/X11/xorg.conf.d/92-exopc-mtev.conf
+%{_sysconfdir}/X11/xorg.conf.d/92-exopc-mtev.conf
+%manifest device-config-touch.manifest