Fix Prevent Issue
[framework/appfw/debug-launchpad.git] / packaging / debug-launchpad.spec
index badd3da..a2232b1 100644 (file)
@@ -1,10 +1,11 @@
 Name:       debug-launchpad
 Summary:    Debug Launchpad
-Version:    0.0.3
+Version:    0.0.10
 Release:    1
-Group:      System/Libraries
+Group:      System Environment/Daemons
 License:    Apache License, Version 2.0
 Source0:    %{name}-%{version}.tar.gz
+BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 Requires(post): /sbin/ldconfig
 Requires(post): /usr/bin/systemctl
@@ -22,6 +23,7 @@ BuildRequires:  pkgconfig(libprivilege-control)
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(libsmack)
 BuildRequires:  pkgconfig(aul)
+BuildRequires:  libcap-devel
 
 
 %description
@@ -31,14 +33,21 @@ Debug launchpad
 %setup -q
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%ifarch %{ix86}
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=x86
+%else
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=arm
+%endif
 make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
 %make_install
 
+%clean
+rm -rf %{buildroot}
+
 %post
 
 %files
-%{_bindir}/debug_launchpad_preloading_preinitializing_daemon
+%attr(0755, root, root) %{_bindir}/debug_launchpad_preloading_preinitializing_daemon