Update Accessibility Event Path.
[platform/framework/web/data-provider-master.git] / packaging / data-provider-master.spec
index ded42fe..c1cf6e3 100644 (file)
@@ -1,6 +1,6 @@
 Name: data-provider-master
 Summary: Master service provider for liveboxes.
-Version: 0.18.3
+Version: 0.24.20
 Release: 1
 Group: HomeTF/Livebox
 License: Flora License
@@ -14,6 +14,7 @@ BuildRequires: pkgconfig(sqlite3)
 BuildRequires: pkgconfig(db-util)
 BuildRequires: pkgconfig(glib-2.0)
 BuildRequires: pkgconfig(gio-2.0)
+BuildRequires: pkgconfig(libsmack)
 BuildRequires: pkgconfig(bundle)
 BuildRequires: pkgconfig(ecore-x)
 BuildRequires: pkgconfig(ecore)
@@ -32,7 +33,12 @@ BuildRequires: pkgconfig(xext)
 BuildRequires: pkgconfig(xdamage)
 BuildRequires: pkgconfig(pkgmgr)
 BuildRequires: pkgconfig(livebox-service)
-BuildRequires: sec-product-features
+BuildRequires: pkgconfig(notification)
+BuildRequires: pkgconfig(badge)
+BuildRequires: pkgconfig(shortcut)
+BuildRequires: pkgconfig(security-server)
+Requires(post): sys-assert
+Requires(post): dbus
 
 %description
 Manage the 2nd stage livebox service provider and communicate with the viewer application.
@@ -42,11 +48,7 @@ Keep trace on the life-cycle of the livebox and status of the service providers,
 %setup -q
 
 %build
-%if 0%(test "%{?sec_build_conf_tizen_product_group}" == "baltic" && echo 1)
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DPRODUCT=baltic
-%else
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DPRODUCT=private
-%endif
 
 CFLAGS="${CFLAGS} -Wall -Winline -Werror" LDFLAGS="${LDFLAGS}" make %{?jobs:-j%jobs}
 
@@ -63,7 +65,7 @@ mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc3.d
 mkdir -p %{buildroot}/%{_libdir}/systemd/user/tizen-middleware.target.wants
 touch %{buildroot}/opt/dbspace/.livebox.db
 touch %{buildroot}/opt/dbspace/.livebox.db-journal
-ln -sf %{_sysconfdir}/rc.d/init.d/data-provider-master %{buildroot}/%{_sysconfdir}/rc.d/rc3.d/S99data-provider-master
+#ln -sf %{_sysconfdir}/rc.d/init.d/data-provider-master %{buildroot}/%{_sysconfdir}/rc.d/rc3.d/S99data-provider-master
 ln -sf %{_libdir}/systemd/user/data-provider-master.service %{buildroot}/%{_libdir}/systemd/user/tizen-middleware.target.wants/data-provider-master.service
 
 %pre
@@ -85,6 +87,7 @@ chown 0:5000 /opt/dbspace/.livebox.db
 chmod 640 /opt/dbspace/.livebox.db
 chown 0:5000 /opt/dbspace/.livebox.db-journal
 chmod 640 /opt/dbspace/.livebox.db-journal
+vconftool set -t bool "memory/data-provider-master/started" 0 -i -u 5000 -f -s system::vconf_system
 echo "Successfully installed. Please start a daemon again manually"
 echo "%{_sysconfdir}/init.d/data-provider-master start"
 
@@ -92,7 +95,7 @@ echo "%{_sysconfdir}/init.d/data-provider-master start"
 %manifest data-provider-master.manifest
 %defattr(-,root,root,-)
 %{_sysconfdir}/rc.d/init.d/data-provider-master
-%{_sysconfdir}/rc.d/rc3.d/S99data-provider-master
+#%{_sysconfdir}/rc.d/rc3.d/S99data-provider-master
 %{_bindir}/data-provider-master
 %{_bindir}/liveinfo
 %{_prefix}/etc/package-manager/parserlib/*
@@ -100,11 +103,9 @@ echo "%{_sysconfdir}/init.d/data-provider-master start"
 %{_libdir}/systemd/user/data-provider-master.service
 %{_libdir}/systemd/user/tizen-middleware.target.wants/data-provider-master.service
 %{_datarootdir}/license/*
-/opt/usr/share/live_magazine
-/opt/usr/share/live_magazine/log
-/opt/usr/share/live_magazine/reader
-/opt/usr/share/live_magazine/always
+/opt/usr/share/live_magazine/*
 /opt/dbspace/.livebox.db
 /opt/dbspace/.livebox.db-journal
+/opt/etc/smack/accesses.d/*
 
 # End of a file