[Tizen] Enable Debug on
[platform/core/uifw/dali-core.git] / packaging / dali.spec
index c3860dc..c76853d 100644 (file)
@@ -1,6 +1,6 @@
 Name:       dali
 Summary:    The OpenGLES Canvas Core Library
-Version:    1.2.38
+Version:    1.2.52
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -66,7 +66,7 @@ Integration development package for the OpenGLES Canvas - headers for integratin
 ##############################
 %build
 PREFIX="/usr"
-CXXFLAGS+=" -Wall -g -Os -DNDEBUG -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -D_GLIBCXX_USE_CXX11_ABI=0 "
+CXXFLAGS+=" -Wall -g -Os -DNDEBUG -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
 LDFLAGS+=" -Wl,--rpath=$PREFIX/lib -Wl,--as-needed -Wl,--gc-sections -lgcc_s -lgcc -lpthread -Wl,-Bsymbolic-functions "
 
 %ifarch %{arm}
@@ -107,9 +107,7 @@ LDFLAGS="${LDFLAGS:-%optflags}" ; export LDFLAGS;
       --sharedstatedir=%{_sharedstatedir} \
       --mandir=%{_mandir} \
       --enable-gles=%{target_gles_version} \
-%if 0%{?enable_debug}
       --enable-debug \
-%endif
       --infodir=%{_infodir}
 
 make %{?jobs:-j%jobs}