ecore-wl2: applying ecore-wl2
[platform/core/uifw/dali-csharp-binder.git] / packaging / dali-csharp-binder.spec
index c851b50..c956399 100755 (executable)
@@ -10,12 +10,24 @@ Source: %{name}-%{version}.tar.xz
 BuildRequires: pkgconfig(dali-core)
 BuildRequires: pkgconfig(dali-adaptor)
 BuildRequires: pkgconfig(dali-toolkit)
-BuildRequires: pkgconfig(ecore-wayland)
 BuildRequires: pkgconfig(widget_viewer_dali)
 
+# dali-adaptor uses ecore mainloop
+%if 0%{?tizen_version_major} >= 5
+BuildRequires:  pkgconfig(ecore-wl2)
+%else
+BuildRequires:  pkgconfig(ecore-wayland)
+%endif
+
 %description
 dali-csharp-binder
 
+%if 0%{?tizen_version_major} >= 5
+CFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
+CXXFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
+configure_flags="--enable-ecore-wl2"
+%endif
+
 ##############################
 # devel
 ##############################
@@ -39,7 +51,9 @@ This package includes developer files common to all packages.
 %build
 %autogen
 # added for key grab binding only for tizen
-%configure --enable-tizenBuild=yes
+%configure --enable-tizenBuild=yes \
+           $configure_flags
+
 make %{?_smp_mflags}
 
 ##############################