ecore-wl2: applying ecore-wl2
[platform/core/uifw/dali-csharp-binder.git] / packaging / dali-csharp-binder.spec
index ad9f276..c956399 100755 (executable)
@@ -1,18 +1,33 @@
+
 Name: dali-csharp-binder
-Version: 1.2.15
-Release: 20170103
+Version: 1.3.9+nui500
+Release: 1
 Summary: build dali csharp binder
-License: TO_BE_FILLED_IN
+License: Apache-2.0 and BSD-3-Clause and MIT
 Group: uifw/graphic
 Source: %{name}-%{version}.tar.xz
 
 BuildRequires: pkgconfig(dali-core)
 BuildRequires: pkgconfig(dali-adaptor)
 BuildRequires: pkgconfig(dali-toolkit)
+BuildRequires: pkgconfig(widget_viewer_dali)
+
+# dali-adaptor uses ecore mainloop
+%if 0%{?tizen_version_major} >= 5
+BuildRequires:  pkgconfig(ecore-wl2)
+%else
+BuildRequires:  pkgconfig(ecore-wayland)
+%endif
 
 %description
 dali-csharp-binder
 
+%if 0%{?tizen_version_major} >= 5
+CFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
+CXXFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
+configure_flags="--enable-ecore-wl2"
+%endif
+
 ##############################
 # devel
 ##############################
@@ -35,6 +50,10 @@ This package includes developer files common to all packages.
 ##############################
 %build
 %autogen
+# added for key grab binding only for tizen
+%configure --enable-tizenBuild=yes \
+           $configure_flags
+
 make %{?_smp_mflags}
 
 ##############################