DALi Version 2.1.12
[platform/core/uifw/dali-csharp-binder.git] / packaging / dali-csharp-binder.spec
index 08ee49b..12bf9bd 100644 (file)
@@ -21,7 +21,7 @@
 
 Name: dali2-csharp-binder
 Summary: The DALI Csharp Binder
-Version: 2.0.36
+Version: 2.1.12
 Release: 1
 Group: uifw/graphic
 License: Apache-2.0 and BSD-3-Clause and MIT
@@ -45,7 +45,12 @@ BuildRequires: pkgconfig
 BuildRequires: pkgconfig(dali2-core)
 BuildRequires: pkgconfig(dali2-adaptor)
 BuildRequires: pkgconfig(dali2-toolkit)
-BuildRequires: pkgconfig(dali2-extension)
+%if "%{_vd_cfg_product_type}" != "AUDIO" && "%{_vd_cfg_product_type}" !="AV"
+%define rive_animation_view 1
+BuildRequires: pkgconfig(dali2-extension-rive-animation-view)
+%endif
+
+
 BuildRequires: pkgconfig(widget_viewer_dali)
 BuildRequires: pkgconfig(watch_viewer_dali)
 BuildRequires: pkgconfig(watch-holder-base)
@@ -205,6 +210,9 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?rive_animation_view}
+           --enable-rive-animation-view \
+%endif
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -219,9 +227,12 @@ for FILE in libdali2-csharp-binder*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{v
 mv pkgconfig/dali2-csharp-binder*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
+%if "%{?profile}" != "mobile"
 make clean
 %endif
 
+%endif
+
 #######################################################################
 # If the profile is selected, the line below is repquired.
 # if tv ||"undefined"
@@ -231,6 +242,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?rive_animation_view}
+           --enable-rive-animation-view \
+%endif
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -245,9 +259,12 @@ for FILE in libdali2-csharp-binder*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{v
 mv pkgconfig/dali2-csharp-binder*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
+%if "%{?profile}" != "tv"
 make clean
 %endif
 
+%endif
+
 #######################################################################
 # If the profile is selected, the line below is repquired.
 # if wearable || "undefined"
@@ -257,6 +274,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?rive_animation_view}
+           --enable-rive-animation-view \
+%endif
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -271,9 +291,12 @@ for FILE in libdali2-csharp-binder*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{v
 mv pkgconfig/dali2-csharp-binder*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
+%if "%{?profile}" != "wearable"
 make clean
 %endif
 
+%endif
+
 #######################################################################
 # If the profile is selected, the line below is repquired.
 # if ivi ||"undefined"
@@ -283,6 +306,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?rive_animation_view}
+           --enable-rive-animation-view \
+%endif
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -297,9 +323,12 @@ for FILE in libdali2-csharp-binder*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{v
 mv pkgconfig/dali2-csharp-binder*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
+%if "%{?profile}" != "ivi"
 make clean
 %endif
 
+%endif
+
 #######################################################################
 # common
 # If the profile is selected, the line below is repquired.
@@ -310,6 +339,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?rive_animation_view}
+           --enable-rive-animation-view \
+%endif
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -324,9 +356,12 @@ for FILE in libdali2-csharp-binder*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{v
 mv pkgconfig/dali2-csharp-binder*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
+%if "%{?profile}" != "common"
 make clean
 %endif
 
+%endif
+
 ##############################
 # Installation
 ##############################