Revert "[4.0] Implement WebEngineLite interface and plugin for Minimized Web Engine"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 3938f8f..eae7c32 100644 (file)
@@ -19,7 +19,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.56
+Version:    1.2.58
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -138,15 +138,6 @@ BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(feedback)
 %endif
 
-# for videoplayer Plugin
-BuildRequires:  pkgconfig(capi-media-player)
-
-# for Web Engine Lite Plugin
-%if 0%{?enable_web_engine_lite}
-BuildRequires: lightweight-web-engine
-BuildRequires: lightweight-web-engine-devel
-%endif
-
 # for multiprofile
 Requires:   %{name}-compat = %{version}-%{release}
 Recommends: %{name}-profile_common = %{version}-%{release}
@@ -377,28 +368,6 @@ Requires:   %{name} = %{version}-%{release}
 %description dali-feedback-plugin
 Feedback plugin to play haptic and audio feedback for Dali
 
-##############################
-# Dali VideoPlayer Plugin
-##############################
-%if %{with wayland}
-
-%package dali-video-player-plugin
-Summary:    Plugin to play a video file for Dali
-Group:      System/Libraries
-%description dali-video-player-plugin
-VideoPlayer plugin to play a video file for Dali
-%endif
-
-##############################
-# Dali WebEngineLite Plugin
-##############################
-
-%package dali-web-engine-lite-plugin
-Summary:    Plugin WebEngineLite for Dali
-Group:      System/Libraries
-%description dali-web-engine-lite-plugin
-WebEngineLite plugin for Dali
-
 %if !0%{?disable_cxx03_build}
 ##############################
 # Dali Feedback Plugin cxx03
@@ -411,27 +380,6 @@ Requires:   %{name}-cxx03 = %{version}-%{release}
 %description dali-feedback-plugin-cxx03
 Feedback plugin to play haptic and audio feedback for Dali
 
-##############################
-# Dali VideoPlayer Plugin
-##############################
-%if %{with wayland}
-
-%package dali-video-player-plugin-cxx03
-Summary:    Plugin to play a video file for Dali with cxx03 abi
-Group:      System/Libraries
-%description dali-video-player-plugin-cxx03
-VideoPlayer plugin to play a video file for Dali
-%endif
-
-##############################
-# Dali WebEngineLite Plugin
-##############################
-
-%package dali-web-engine-lite-plugin-cxx03
-Summary:    Plugin WebEngineLite for Dali with cxx03 abi
-Group:      System/Libraries
-%description dali-web-engine-lite-plugin-cxx03
-WebEngineLite plugin for Dali
 %endif
 
 ##############################
@@ -520,7 +468,6 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -529,9 +476,6 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -566,7 +510,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -575,9 +518,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -611,7 +551,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -620,9 +559,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -656,7 +592,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -665,9 +600,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -693,7 +625,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -703,7 +635,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -712,9 +643,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -757,7 +685,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -767,9 +694,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -804,7 +728,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -814,9 +737,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -850,7 +770,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -860,9 +779,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -896,7 +812,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -906,9 +821,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -932,7 +844,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -943,7 +855,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -953,9 +864,6 @@ make clean
 %else
            --enable-efl=yes \
 %endif
-%if 0%{?enable_web_engine_lite}
-           --enable-web-engine-lite \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -1082,24 +990,6 @@ exit 0
 /sbin/ldconfig
 exit 0
 
-%if %{with wayland}
-%post dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-%if %{with wayland}
-%postun dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-#%if %{with wayland}
-%post dali-web-engine-lite-plugin
-/sbin/ldconfig
-exit 0
-#%endif
-
 ##############################
 
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
@@ -1283,23 +1173,7 @@ exit 0
 %exclude %{_libdir}/libdali-adap*.so*.ivi
 #%endif
 
-%if %{with wayland}
-%files dali-video-player-plugin-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin.so*
-%license LICENSE
-%endif
-
 %if 0%{?tizen_version_major} >= 3
-%if 0%{?enable_web_engine_lite}
-%files dali-web-engine-lite-plugin-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-web-engine-lite-plugin.so*
-%license LICENSE
-%endif
-
 %files dali-feedback-plugin-cxx03
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
@@ -1310,23 +1184,7 @@ exit 0
 
 #################################################
 
-%if %{with wayland}
-%files dali-video-player-plugin
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin-cxx11.so*
-%license LICENSE
-%endif
-
 %if 0%{?tizen_version_major} >= 3
-%if 0%{?enable_web_engine_lite}
-%files dali-web-engine-lite-plugin
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-web-engine-lite-plugin-cxx11.so*
-%license LICENSE
-%endif
-
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)