Update license information in the spec file
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index cc3a88f..cc6eade 100644 (file)
@@ -2,27 +2,23 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.0.39
+Version:    1.0.51
 Release:    1
 Group:      System/Libraries
-License:    Apache-2.0
+License:    Apache-2.0, BSD-2.0, MIT
 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
 Source0:    %{name}-%{version}.tar.gz
 
 %if "%{profile}" == "mobile"
 %define dali_profile MOBILE
 %define dali_feedback_plugin 0
-%define dali_bullet_plugin 0
-%define dali_assimp_plugin 0
-%define over_tizen_2_2 0
+%define over_tizen_2_2 1
 %define shaderbincache_flag DISABLE
 %endif
 
 %if "%{profile}" == "tv"
 %define dali_profile TV
 %define dali_feedback_plugin 0
-%define dali_bullet_plugin 0
-%define dali_assimp_plugin 0
 %define over_tizen_2_2 1
 %define shaderbincache_flag ENABLE
 %endif
@@ -30,19 +26,14 @@ Source0:    %{name}-%{version}.tar.gz
 %if "%{profile}" == "wearable"
 %define dali_profile WEARABLE
 %define dali_feedback_plugin 0
-%define dali_bullet_plugin 0
-%define dali_assimp_plugin 0
-%define over_tizen_2_2 0
+%define over_tizen_2_2 1
 %define shaderbincache_flag DISABLE
 %endif
 
 %if "%{profile}" == "common"
 %define dali_profile COMMON
 %define dali_feedback_plugin 0
-%define dali_bullet_plugin 0
-%define dali_assimp_plugin 0
 %define over_tizen_2_2 0
-
 %define shaderbincache_flag DISABLE
 %endif
 
@@ -86,6 +77,7 @@ BuildRequires:  pkgconfig(ecore-wayland)
 BuildRequires:  pkgconfig(wayland-egl)
 BuildRequires:  pkgconfig(wayland-client)
 %else
+BuildRequires:  pkgconfig(xext)
 BuildRequires:  pkgconfig(xi)
 BuildRequires:  pkgconfig(xfixes)
 BuildRequires:  pkgconfig(xdamage)
@@ -95,10 +87,6 @@ BuildRequires:  pkgconfig(utilX)
 BuildRequires:  pkgconfig(harfbuzz)
 BuildRequires:  fribidi-devel
 
-%if 0%{?dali_assimp_plugin}
-BuildRequires:  pkgconfig(assimp)
-%endif
-
 %description
 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
 platform abstraction and application shell
@@ -111,6 +99,7 @@ Summary:    Development components for the DALi Tizen Adaptor
 Group:      Development/Building
 Requires:   %{name} = %{version}-%{release}
 Requires:   %{name}-integration-devel = %{version}-%{release}
+Requires:   boost-devel
 
 %description devel
 Development components for the DALi Tizen Adaptor - public headers and package configs
@@ -143,33 +132,18 @@ BuildRequires:  libfeedback-devel
 Feedback plugin to play haptic and audio feedback for Dali
 
 ##############################
-# Dali Dynamics/Bullet Plugin
-##############################
-%package dali-bullet-plugin
-Summary:    Plugin to provide physics
-Group:      System/Libraries
-%if 0%{?dali_bullet_plugin}
-BuildRequires:  pkgconfig(bullet)
-%endif
-
-%description dali-bullet-plugin
-Dynamics plugin to wrap the libBulletDynamics libraries
-
-##############################
 # Preparation
 ##############################
 %prep
 %setup -q
 %define dali_data_rw_dir         /usr/share/dali/
 %define dali_data_ro_dir         /usr/share/dali/
-%define user_font_cache_dir      %{dali_data_rw_dir}/glyphcache/
 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
 %define font_preloaded_path      /usr/share/fonts/
 %define font_downloaded_path     /opt/share/fonts/
 %define font_application_path    /usr/share/app_fonts/
 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
 %define dali_plugin_sound_files  %{dali_data_ro_dir}/plugins/sounds/
-%define dali_plugin_theme_files  %{dali_data_ro_dir}/themes/feedback-themes/
 
 %define dev_include_path %{_includedir}
 
@@ -204,12 +178,6 @@ cd %{_builddir}/%{name}-%{version}/build/tizen && CXXFLAGS=$CXXFLAGS LDFLAGS=$LD
 %if 0%{?dali_feedback_plugin}
            --enable-feedback \
 %endif
-%if 0%{?dali_bullet_plugin}
-           --enable-bullet \
-%endif
-%if 0%{?dali_assimp_plugin}
-           --enable-assimp \
-%endif
 %if 0%{?over_tizen_2_2}
            --with-over-tizen_2_2 \
 %endif
@@ -240,7 +208,6 @@ cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{
 ##############################
 
 %pre
-rm -f %{user_font_cache_dir}/*
 exit 0
 
 ##############################
@@ -248,7 +215,6 @@ exit 0
 ##############################
 %post
 /sbin/ldconfig
-chown 5000:5000 %{user_font_cache_dir}
 exit 0
 
 %if 0%{?dali_feedback_plugin}
@@ -257,17 +223,10 @@ exit 0
 exit 0
 %endif
 
-%if 0%{?dali_bullet_plugin}
-%post dali-bullet-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
 ##############################
 #   Pre Uninstall old package
 ##############################
 %preun
-rm -f %{user_font_cache_dir}/*
 exit 0
 
 ##############################
@@ -283,12 +242,6 @@ exit 0
 exit 0
 %endif
 
-%if 0%{?dali_bullet_plugin}
-%postun dali-bullet-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
 ##############################
 # Files in Binary Packages
 ##############################
@@ -298,7 +251,6 @@ exit 0
 %defattr(-,root,root,-)
 %{_libdir}/libdali-adap*.so*
 %defattr(-,app,app,-)
-%dir %{user_font_cache_dir}
 %dir %{user_shader_cache_dir}
 %{_bindir}/*
 %{_datadir}/license/%{name}
@@ -307,6 +259,7 @@ exit 0
 %defattr(-,root,root,-)
 %{dev_include_path}/dali/dali.h
 %{dev_include_path}/dali/public-api/*
+%{dev_include_path}/dali/devel-api/*
 %{_libdir}/pkgconfig/dali.pc
 
 %files integration-devel
@@ -319,11 +272,5 @@ exit 0
 %defattr(-,root,root,-)
 %{_libdir}/libdali-feedback-plugin.so*
 %{dali_plugin_sound_files}/*
-%{dali_plugin_theme_files}/*
 %endif
 
-%if 0%{?dali_bullet_plugin}
-%files dali-bullet-plugin
-%defattr(-,root,root,-)
-%{_libdir}/libdali-bullet-plugin.so*
-%endif