[Tizen] Add new keys for TV
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index d4fe83f..9d5eb61 100644 (file)
@@ -19,7 +19,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.42
+Version:    1.2.46
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -72,6 +72,7 @@ BuildRequires:  pkgconfig(egl)
 BuildRequires:  libcurl-devel
 BuildRequires:  pkgconfig(harfbuzz)
 BuildRequires:  fribidi-devel
+
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
@@ -118,7 +119,9 @@ BuildRequires:  pkgconfig(capi-system-system-settings)
 
 # for feedback plugin
 BuildRequires:  pkgconfig(mm-sound)
+%if 0%{?tizen_version_major} >= 3
 BuildRequires:  pkgconfig(feedback)
+%endif
 
 # for videoplayer Plugin
 BuildRequires:  pkgconfig(capi-media-player)
@@ -140,12 +143,12 @@ platform abstraction and application shell
 # if mobile || "undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 %package profile_mobile
-Summary:       The DALi Tizen Adaptor for mobile
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_tv
-Conflicts:     %{name}-profile_wearable
-Conflicts:     %{name}-profile_ivi
-Conflicts:     %{name}-profile_common
+Summary:        The DALi Tizen Adaptor for mobile
+Provides:       %{name}-compat = %{version}-%{release}
+Conflicts:      %{name}-profile_tv
+Conflicts:      %{name}-profile_wearable
+Conflicts:      %{name}-profile_ivi
+Conflicts:      %{name}-profile_common
 %description profile_mobile
 The DALi Tizen Adaptor for mobile.
 %endif
@@ -154,12 +157,12 @@ The DALi Tizen Adaptor for mobile.
 # if tv ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 %package profile_tv
-Summary:       The DALi Tizen Adaptor for tv
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile
-Conflicts:     %{name}-profile_wearable
-Conflicts:     %{name}-profile_ivi
-Conflicts:     %{name}-profile_common
+Summary:        The DALi Tizen Adaptor for tv
+Provides:       %{name}-compat = %{version}-%{release}
+Conflicts:      %{name}-profile_mobile
+Conflicts:      %{name}-profile_wearable
+Conflicts:      %{name}-profile_ivi
+Conflicts:      %{name}-profile_common
 %description profile_tv
 The DALi Tizen Adaptor for tv.
 %endif
@@ -168,12 +171,12 @@ The DALi Tizen Adaptor for tv.
 # if wearable || "undefined"
 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 %package profile_wearable
-Summary:       The DALi Tizen Adaptor for wearable
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile
-Conflicts:     %{name}-profile_tv
-Conflicts:     %{name}-profile_ivi
-Conflicts:     %{name}-profile_common
+Summary:        The DALi Tizen Adaptor for wearable
+Provides:       %{name}-compat = %{version}-%{release}
+Conflicts:      %{name}-profile_mobile
+Conflicts:      %{name}-profile_tv
+Conflicts:      %{name}-profile_ivi
+Conflicts:      %{name}-profile_common
 %description profile_wearable
 The DALi Tizen Adaptor for wearable.
 %endif
@@ -182,12 +185,12 @@ The DALi Tizen Adaptor for wearable.
 # if ivi ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
 %package profile_ivi
-Summary:       The DALi Tizen Adaptor for ivi
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile
-Conflicts:     %{name}-profile_wearable
-Conflicts:     %{name}-profile_tv
-Conflicts:     %{name}-profile_common
+Summary:        The DALi Tizen Adaptor for ivi
+Provides:       %{name}-compat = %{version}-%{release}
+Conflicts:      %{name}-profile_mobile
+Conflicts:      %{name}-profile_wearable
+Conflicts:      %{name}-profile_tv
+Conflicts:      %{name}-profile_common
 %description profile_ivi
 The DALi Tizen Adaptor for ivi.
 %endif
@@ -198,12 +201,12 @@ The DALi Tizen Adaptor for ivi.
 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
 %package profile_common
 %define tizen_2_2_compatibility 0
-Summary:  The DALi Tizen Adaptor for common
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile
-Conflicts:     %{name}-profile_wearable
-Conflicts:     %{name}-profile_tv
-Conflicts:     %{name}-profile_ivi
+Summary:        The DALi Tizen Adaptor for common
+Provides:       %{name}-compat = %{version}-%{release}
+Conflicts:      %{name}-profile_mobile
+Conflicts:      %{name}-profile_wearable
+Conflicts:      %{name}-profile_tv
+Conflicts:      %{name}-profile_ivi
 %description profile_common
 The DALi Tizen Adaptor for common.
 %endif
@@ -234,13 +237,12 @@ Integration development package for the Adaptor - headers for integrating with a
 ##############################
 # Dali Feedback Plugin
 ##############################
-
 %package dali-feedback-plugin
 Summary:    Plugin to play haptic and audio feedback for Dali
 Group:      System/Libraries
 Requires:   %{name} = %{version}-%{release}
 %description dali-feedback-plugin
-eedback plugin to play haptic and audio feedback for Dali
+Feedback plugin to play haptic and audio feedback for Dali
 
 ##############################
 # Dali VideoPlayer Plugin
@@ -326,6 +328,7 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 #--enable-appfw=yes \ # affects both dali-adaptor & dali-adaptor-uv
 #--with-libuv=/usr/include/node/ \ # only affects dali-adaptor-uv
 
+
 # Set up the build via configure.
 #######################################################################
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
@@ -333,7 +336,9 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
+%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
+%endif
            --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -369,7 +374,9 @@ popd
 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=TV \
+%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
+%endif
            --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -405,7 +412,9 @@ popd
 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
+%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
+%endif
            --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -441,7 +450,9 @@ popd
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=IVI \
+%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
+%endif
            --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -478,7 +489,9 @@ popd
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
+%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
+%endif
            --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -509,6 +522,7 @@ rm -rf %{buildroot}
 pushd %{_builddir}/%{name}-%{version}/build/tizen
 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
 
+
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # !unified && (wearable || tv || ivi || mobile)
 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
@@ -522,9 +536,6 @@ for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
 %endif
 popd
 
-mkdir -p %{buildroot}/usr/share/license
-cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
-
 ##############################
 # Upgrade order:
 # 1 - Pre Install new package
@@ -539,15 +550,21 @@ cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{
 exit 0
 
 ##############################
-#  Post, Preun, Postun Install new package
+#  Post Install new package
 ##############################
 %post
 /sbin/ldconfig
 exit 0
 
+##############################
+#  Pre Uninstall old package
+##############################
 %preun
 exit 0
 
+##############################
+#  Post Uninstall old package
+##############################
 %postun
 /sbin/ldconfig
 exit 0
@@ -564,6 +581,7 @@ exit 0
 exit 0
 %endif
 
+
 ##############################
 
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
@@ -643,7 +661,8 @@ exit 0
 %defattr(-,app,app,-)
 %dir %{user_shader_cache_dir}
 %{_bindir}/*
-%{_datadir}/license/%{name}
+%license LICENSE
+
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -660,13 +679,16 @@ exit 0
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libdali-video-player-plugin.so*
+%license LICENSE
 %endif
 
+%if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libdali-feedback-plugin.so*
 %{dali_plugin_sound_files}/*
+%endif
 
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"