Revert "[Tizen] Implement WebEngineLite interface and plugin for Minimized Web Engine"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 762766b..77a92a7 100644 (file)
@@ -19,7 +19,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.52
+Version:    1.2.54
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -104,10 +104,10 @@ BuildRequires:  pkgconfig(utilX)
 
 # for dali-adaptor
 BuildRequires:  pkgconfig(evas)
-BuildRequires:  pkgconfig(elementary)
 
 %if 0%{?tizen_version_major} == 3
 BuildRequires:  pkgconfig(capi-appfw-application)
+BuildRequires:  pkgconfig(elementary)
 %else
 BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(appcore-ui)
@@ -115,7 +115,9 @@ BuildRequires:  pkgconfig(appcore-multiwindow)
 BuildRequires:  pkgconfig(capi-appfw-app-common)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
 BuildRequires:  pkgconfig(screen_connector_provider)
+BuildRequires:  pkgconfig(ecore-imf)
 %endif
+
 BuildRequires:  pkgconfig(capi-system-system-settings)
 
 # for feedback plugin
@@ -351,7 +353,9 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_debug}
            --enable-debug \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir}
 
@@ -390,7 +394,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_debug}
            --enable-debug \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir}
 
@@ -428,7 +434,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_debug}
            --enable-debug \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir}
 
@@ -466,7 +474,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_debug}
            --enable-debug \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir}
 
@@ -505,7 +515,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_debug}
            --enable-debug \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir}