Distinguish tizen version via tizen_version_major
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 8f9b1a4..5ee2695 100644 (file)
@@ -14,7 +14,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.1.18
+Version:    1.1.20
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-2-Clause and MIT
@@ -25,8 +25,9 @@ Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 Requires:       giflib
 
-# Get the profile from tizen_profile_name if it exists.
-%if 0%{?tizen_profile_name:1}
+# Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
+
+%if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
 %define profile %{tizen_profile_name}
 %endif
 
@@ -112,6 +113,9 @@ BuildRequires:  libxkbcommon-devel
 # dali-adaptor uses ecore mainloop
 BuildRequires:  pkgconfig(ecore-wayland)
 
+# dali-adaptor needs tbm_surface in tizen 3.0 wayland
+BuildRequires:  pkgconfig(libtbm)
+
 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
 BuildRequires:  pkgconfig(tpkp-curl)