[Tizen] Implement WebEngineLite interface and plugin for Minimized Web Engine
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index c4616dd..54afd22 100644 (file)
@@ -19,7 +19,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.46
+Version:    1.2.54
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -37,7 +37,6 @@ Requires:       giflib
 BuildRequires:  pkgconfig(libtzplatform-config)
 %endif
 
-
 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
 
 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
@@ -76,11 +75,6 @@ BuildRequires:  fribidi-devel
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
-# Tizen currently does not have libuv as a separate libuv package
-# So we have to look into the uv headers bundled inside node-js
-BuildRequires:  nodejs-devel
-
-
 %if %{with wayland}
 
 ####### BUILDING FOR WAYLAND #######
@@ -89,9 +83,6 @@ BuildRequires:  pkgconfig(wayland-client)
 BuildRequires:  wayland-devel
 BuildRequires:  wayland-extension-client-devel
 
-# dali-adaptor-uv uses libuv mainloop and has its own wayland client (it needs wayland-client headers).
-BuildRequires:  libxkbcommon-devel
-
 # dali-adaptor uses ecore mainloop
 BuildRequires:  pkgconfig(ecore-wayland)
 
@@ -113,8 +104,20 @@ BuildRequires:  pkgconfig(utilX)
 
 # for dali-adaptor
 BuildRequires:  pkgconfig(evas)
-BuildRequires:  pkgconfig(elementary)
+
+%if 0%{?tizen_version_major} == 3
 BuildRequires:  pkgconfig(capi-appfw-application)
+BuildRequires:  pkgconfig(elementary)
+%else
+BuildRequires:  pkgconfig(bundle)
+BuildRequires:  pkgconfig(appcore-ui)
+BuildRequires:  pkgconfig(appcore-multiwindow)
+BuildRequires:  pkgconfig(capi-appfw-app-common)
+BuildRequires:  pkgconfig(capi-appfw-app-control)
+BuildRequires:  pkgconfig(screen_connector_provider)
+BuildRequires:  pkgconfig(ecore-imf)
+%endif
+
 BuildRequires:  pkgconfig(capi-system-system-settings)
 
 # for feedback plugin
@@ -126,6 +129,10 @@ BuildRequires:  pkgconfig(feedback)
 # for videoplayer Plugin
 BuildRequires:  pkgconfig(capi-media-player)
 
+# for Web Engine Lite Plugin
+%if 0%{?enable_web_engine_lite}
+BuildRequires: lightweight-web-engine
+%endif
 
 # for multiprofile
 Requires:   %{name}-compat = %{version}-%{release}
@@ -257,6 +264,16 @@ VideoPlayer plugin to play a video file for Dali
 %endif
 
 ##############################
+# Dali WebEngineLite Plugin
+##############################
+
+%package dali-web-engine-lite-plugin
+Summary:    Plugin WebEngineLite for Dali
+Group:      System/Libraries
+%description dali-web-engine-lite-plugin
+WebEngineLite plugin for Dali
+
+##############################
 # Preparation
 ##############################
 %prep
@@ -302,6 +319,11 @@ CXXFLAGS+=" -DWAYLAND"
 configure_flags="--enable-wayland"
 %endif
 
+# Use this conditional when Tizen version is 4.x or greater
+%if 0%{?tizen_version_major} >= 4
+CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
+%endif
+
 %if 0%{?tizen_2_2_compatibility}
 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
@@ -324,11 +346,6 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 # Default to GLES 2.0 if not specified.
 %define target_gles_version 20
 
-#--enable-efl=no \ # only affects dali-adaptor-uv
-#--enable-appfw=yes \ # affects both dali-adaptor & dali-adaptor-uv
-#--with-libuv=/usr/include/node/ \ # only affects dali-adaptor-uv
-
-
 # Set up the build via configure.
 #######################################################################
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
@@ -337,6 +354,7 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
+           --enable-tizen-major-version=%{tizen_version_major} \
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
@@ -349,11 +367,13 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
            --enable-appfw=yes \
-           --with-libuv=/usr/include/node/ \
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -378,6 +398,7 @@ make clean
 
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=TV \
+           --enable-tizen-major-version=%{tizen_version_major} \
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
@@ -390,11 +411,13 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
            --enable-appfw=yes \
-           --with-libuv=/usr/include/node/ \
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -418,6 +441,7 @@ make clean
 
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
+           --enable-tizen-major-version=%{tizen_version_major} \
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
@@ -430,11 +454,13 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
            --enable-appfw=yes \
-           --with-libuv=/usr/include/node/ \
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -458,6 +484,7 @@ make clean
 
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=IVI \
+           --enable-tizen-major-version=%{tizen_version_major} \
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
@@ -470,11 +497,13 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
            --enable-appfw=yes \
-           --with-libuv=/usr/include/node/ \
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -499,6 +528,7 @@ make clean
 
 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
+           --enable-tizen-major-version=%{tizen_version_major} \
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
@@ -511,11 +541,13 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
            --enable-appfw=yes \
-           --with-libuv=/usr/include/node/ \
            $configure_flags --libdir=%{_libdir}
 
 # Build.
@@ -592,6 +624,11 @@ exit 0
 exit 0
 %endif
 
+#%if %{with wayland}
+%post dali-web-engine-lite-plugin
+/sbin/ldconfig
+exit 0
+#%endif
 
 ##############################
 
@@ -694,6 +731,14 @@ exit 0
 %endif
 
 %if 0%{?tizen_version_major} >= 3
+%if 0%{?enable_web_engine_lite}
+%files dali-web-engine-lite-plugin
+%manifest dali-adaptor.manifest
+%defattr(-,root,root,-)
+%{_libdir}/libdali-web-engine-lite-plugin.so*
+%license LICENSE
+%endif
+
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
@@ -752,7 +797,6 @@ exit 0
 %{dev_include_path}/dali/devel-api/*
 %{dev_include_path}/dali/doc/*
 %{_libdir}/pkgconfig/dali-adaptor.pc
-%{_libdir}/pkgconfig/dali-adaptor-uv.pc
 
 %files integration-devel
 %defattr(-,root,root,-)