Removed remaining references to glyph cache
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 839b8d4..4438446 100644 (file)
@@ -2,7 +2,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.0.32
+Version:    1.0.41
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0
@@ -42,6 +42,7 @@ Source0:    %{name}-%{version}.tar.gz
 %define dali_bullet_plugin 0
 %define dali_assimp_plugin 0
 %define over_tizen_2_2 0
+
 %define shaderbincache_flag DISABLE
 %endif
 
@@ -75,6 +76,11 @@ BuildRequires:  pkgconfig(glesv2)
 BuildRequires:  pkgconfig(egl)
 BuildRequires:  libcurl-devel
 
+
+%if 0%{?over_tizen_2_2}
+BuildRequires:  pkgconfig(capi-system-info)
+%endif
+
 %if %{with wayland}
 BuildRequires:  pkgconfig(ecore-wayland)
 BuildRequires:  pkgconfig(wayland-egl)
@@ -104,11 +110,23 @@ platform abstraction and application shell
 Summary:    Development components for the DALi Tizen Adaptor
 Group:      Development/Building
 Requires:   %{name} = %{version}-%{release}
+Requires:   %{name}-integration-devel = %{version}-%{release}
 
 %description devel
 Development components for the DALi Tizen Adaptor - public headers and package configs
 
 ##############################
+# integration-devel
+##############################
+%package integration-devel
+Summary:    Integration development package for the Adaptor
+Group:      Development/Building
+Requires:   %{name} = %{version}-%{release}
+
+%description integration-devel
+Integration development package for the Adaptor - headers for integrating with an adaptor library.
+
+##############################
 # Dali Feedback Plugin
 ##############################
 %package dali-feedback-plugin
@@ -144,7 +162,6 @@ Dynamics plugin to wrap the libBulletDynamics libraries
 %setup -q
 %define dali_data_rw_dir         /usr/share/dali/
 %define dali_data_ro_dir         /usr/share/dali/
-%define user_font_cache_dir      %{dali_data_rw_dir}/glyphcache/
 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
 %define font_preloaded_path      /usr/share/fonts/
 %define font_downloaded_path     /opt/share/fonts/
@@ -192,6 +209,9 @@ cd %{_builddir}/%{name}-%{version}/build/tizen && CXXFLAGS=$CXXFLAGS LDFLAGS=$LD
 %if 0%{?dali_assimp_plugin}
            --enable-assimp \
 %endif
+%if 0%{?over_tizen_2_2}
+           --with-over-tizen_2_2 \
+%endif
            $configure_flags --libdir=%{_libdir}
 
 make %{?jobs:-j%jobs}
@@ -219,7 +239,6 @@ cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{
 ##############################
 
 %pre
-rm -f %{user_font_cache_dir}/*
 exit 0
 
 ##############################
@@ -227,7 +246,6 @@ exit 0
 ##############################
 %post
 /sbin/ldconfig
-chown 5000:5000 %{user_font_cache_dir}
 exit 0
 
 %if 0%{?dali_feedback_plugin}
@@ -246,7 +264,6 @@ exit 0
 #   Pre Uninstall old package
 ##############################
 %preun
-rm -f %{user_font_cache_dir}/*
 exit 0
 
 ##############################
@@ -277,15 +294,20 @@ exit 0
 %defattr(-,root,root,-)
 %{_libdir}/libdali-adap*.so*
 %defattr(-,app,app,-)
-%dir %{user_font_cache_dir}
 %dir %{user_shader_cache_dir}
 %{_bindir}/*
 %{_datadir}/license/%{name}
 
 %files devel
 %defattr(-,root,root,-)
-%{dev_include_path}/dali/*
-%{_libdir}/pkgconfig/dali*.pc
+%{dev_include_path}/dali/dali.h
+%{dev_include_path}/dali/public-api/*
+%{_libdir}/pkgconfig/dali.pc
+
+%files integration-devel
+%defattr(-,root,root,-)
+%{dev_include_path}/dali/integration-api/adaptors/*
+%{_libdir}/pkgconfig/dali-adaptor-integration.pc
 
 %if 0%{?dali_feedback_plugin}
 %files dali-feedback-plugin