Revert "[Tizen] ecore-wl2: add zxdg_shell define"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 761cb42..30eefbd 100644 (file)
 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
 %endif
 
-%bcond_with wayland
+%bcond_without wayland
+%bcond_with x
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.55
+Version:    1.3.17
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -57,6 +58,7 @@ BuildRequires:  pkgconfig(screen_connector_provider)
 
 BuildRequires:  pkgconfig(gles20)
 BuildRequires:  pkgconfig(glesv2)
+BuildRequires:  pkgconfig(ttrace)
 
 %if !0%{?disable_cxx03_build}
 BuildRequires:  dali-devel-cxx03
@@ -84,6 +86,8 @@ BuildRequires:  fribidi-devel
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
+BuildRequires:  pkgconfig(libcrypto)
+
 %if %{with wayland}
 
 ####### BUILDING FOR WAYLAND #######
@@ -93,7 +97,11 @@ BuildRequires:  wayland-devel
 BuildRequires:  wayland-extension-client-devel
 
 # dali-adaptor uses ecore mainloop
+%if 0%{?tizen_version_major} >= 5
+BuildRequires:  pkgconfig(ecore-wl2)
+%else
 BuildRequires:  pkgconfig(ecore-wayland)
+%endif
 
 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
 BuildRequires:  pkgconfig(libtbm)
@@ -115,13 +123,13 @@ BuildRequires:  pkgconfig(utilX)
 %endif
 
 # for dali-adaptor
-BuildRequires:  pkgconfig(evas)
-
 %if 0%{?tizen_version_major} == 3
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(elementary)
 %else
 BuildRequires:  pkgconfig(appcore-ui)
+BuildRequires:  pkgconfig(appcore-widget-base)
+BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(capi-appfw-app-common)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
 BuildRequires:  pkgconfig(ecore-imf)
@@ -135,9 +143,11 @@ BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(feedback)
 %endif
 
-# for videoplayer Plugin
-BuildRequires:  pkgconfig(capi-media-player)
-
+# for Web Engine Lite Plugin
+%if 0%{?enable_web_engine_lite}
+BuildRequires: lightweight-web-engine
+BuildRequires: lightweight-web-engine-devel
+%endif
 
 # for multiprofile
 Requires:   %{name}-compat = %{version}-%{release}
@@ -370,16 +380,14 @@ Requires:   %{name} = %{version}-%{release}
 Feedback plugin to play haptic and audio feedback for Dali
 
 ##############################
-# Dali VideoPlayer Plugin
+# Dali WebEngineLite Plugin
 ##############################
-%if %{with wayland}
 
-%package dali-video-player-plugin
-Summary:    Plugin to play a video file for Dali
+%package dali-web-engine-lite-plugin
+Summary:    Plugin WebEngineLite for Dali
 Group:      System/Libraries
-%description dali-video-player-plugin
-VideoPlayer plugin to play a video file for Dali
-%endif
+%description dali-web-engine-lite-plugin
+WebEngineLite plugin for Dali
 
 %if !0%{?disable_cxx03_build}
 ##############################
@@ -394,16 +402,14 @@ Requires:   %{name}-cxx03 = %{version}-%{release}
 Feedback plugin to play haptic and audio feedback for Dali
 
 ##############################
-# Dali VideoPlayer Plugin
+# Dali WebEngineLite Plugin
 ##############################
-%if %{with wayland}
 
-%package dali-video-player-plugin-cxx03
-Summary:    Plugin to play a video file for Dali with cxx03 abi
+%package dali-web-engine-lite-plugin-cxx03
+Summary:    Plugin WebEngineLite for Dali with cxx03 abi
 Group:      System/Libraries
-%description dali-video-player-plugin-cxx03
-VideoPlayer plugin to play a video file for Dali
-%endif
+%description dali-web-engine-lite-plugin-cxx03
+WebEngineLite plugin for Dali
 %endif
 
 ##############################
@@ -449,12 +455,16 @@ CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
 %if %{with wayland}
 CFLAGS+=" -DWAYLAND"
 CXXFLAGS+=" -DWAYLAND"
+%if 0%{?tizen_version_major} >= 5
+CFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
+CXXFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
+%endif
 configure_flags="--enable-wayland"
 %endif
 
 # Use this conditional when Tizen version is 4.x or greater
-%if 0%{?tizen_version_major} >= 4
-CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
+%if 0%{?tizen_version_major} >= 5
+CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
 %endif
 
 %if 0%{?tizen_2_2_compatibility}
@@ -492,7 +502,6 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -501,6 +510,9 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -535,7 +547,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -544,6 +555,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -577,7 +591,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -586,6 +599,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -619,7 +635,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -628,6 +643,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -653,7 +671,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -663,7 +681,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -672,6 +689,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -714,7 +734,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -724,6 +743,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -758,7 +780,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -768,6 +789,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -801,7 +825,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -811,6 +834,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -844,7 +870,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -854,6 +879,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -877,7 +905,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -888,7 +916,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -898,6 +925,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -1024,18 +1054,11 @@ exit 0
 /sbin/ldconfig
 exit 0
 
-%if %{with wayland}
-%post dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-%if %{with wayland}
-%postun dali-video-player-plugin
+#%if %{with wayland}
+%post dali-web-engine-lite-plugin
 /sbin/ldconfig
 exit 0
-%endif
-
+#%endif
 
 ##############################
 
@@ -1210,7 +1233,7 @@ exit 0
 %license LICENSE
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
+#%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 %defattr(-,root,root,-)
 %{_libdir}/libdali-adaptor.so.0*
 %{_libdir}/libdali-adaptor-cxx03.so
@@ -1218,17 +1241,17 @@ exit 0
 %exclude %{_libdir}/libdali-adap*.so*.wearable
 %exclude %{_libdir}/libdali-adap*.so*.tv
 %exclude %{_libdir}/libdali-adap*.so*.ivi
-%endif
+#%endif
 
-%if %{with wayland}
-%files dali-video-player-plugin-cxx03
+%if 0%{?tizen_version_major} >= 3
+%if 0%{?enable_web_engine_lite}
+%files dali-web-engine-lite-plugin-cxx03
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin.so*
+%{_libdir}/libdali-web-engine-lite-plugin.so*
 %license LICENSE
 %endif
 
-%if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin-cxx03
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
@@ -1239,15 +1262,15 @@ exit 0
 
 #################################################
 
-%if %{with wayland}
-%files dali-video-player-plugin
+%if 0%{?tizen_version_major} >= 3
+%if 0%{?enable_web_engine_lite}
+%files dali-web-engine-lite-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin-cxx11.so*
+%{_libdir}/libdali-web-engine-lite-plugin-cxx11.so*
 %license LICENSE
 %endif
 
-%if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)