DALi Version 1.2.37
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 3e334f4..11e5c15 100644 (file)
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.1.38
+Version:    1.2.37
 Release:    1
 Group:      System/Libraries
-License:    Apache-2.0 and BSD-2-Clause and MIT
+License:    Apache-2.0 and BSD-3-Clause and MIT
 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
 Source0:    %{name}-%{version}.tar.gz
 
@@ -25,6 +25,14 @@ Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 Requires:       giflib
 
+#need libtzplatform-config for directory if tizen version is 3.x
+
+%if 0%{?tizen_version_major} >= 3
+%define tizen_platform_config_supported 1
+BuildRequires:  pkgconfig(libtzplatform-config)
+%endif
+
+
 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
 
 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
@@ -44,7 +52,7 @@ BuildRequires:  pkgconfig(gles20)
 %define dali_profile TV
 %define dali_feedback_plugin 0
 %define dali_videoplayer_plugin 1
-%define shaderbincache_flag ENABLE
+%define shaderbincache_flag DISABLE
 BuildRequires:  pkgconfig(glesv2)
 %define gles_requirement_setup 1
 %endif
@@ -60,11 +68,20 @@ BuildRequires:  pkgconfig(appcore-watch)
 %define gles_requirement_setup 1
 %endif
 
+%if "%{profile}" == "ivi"
+%define dali_profile IVI
+%define dali_feedback_plugin 0
+%define dali_videoplayer_plugin 1
+%define shaderbincache_flag DISABLE
+BuildRequires:  pkgconfig(glesv2)
+%define gles_requirement_setup 1
+%endif
+
 %if "%{profile}" == "common"
 %define dali_profile COMMON
 %define dali_feedback_plugin 0
-%define dali_videoplayer_plugin 0
-%define tizen_2_2_compatibility 1
+%define dali_videoplayer_plugin 1
+%define tizen_2_2_compatibility 0
 %define shaderbincache_flag DISABLE
 BuildRequires:  pkgconfig(glesv2)
 %define gles_requirement_setup 1
@@ -211,15 +228,27 @@ VideoPlayer plugin to play a video file for Dali
 ##############################
 %prep
 %setup -q
+
+#Use TZ_PATH when tizen version is 3.x or greater
+
+%if 0%{?tizen_version_major} >= 3
+%define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
+%define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
+%define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
+%define font_downloaded_path     %TZ_SYS_SHARE/fonts/
+%define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
+%define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
+%else
 %define dali_data_rw_dir         /usr/share/dali/
 %define dali_data_ro_dir         /usr/share/dali/
-%define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
 %define font_preloaded_path      /usr/share/fonts/
 %define font_downloaded_path     /opt/share/fonts/
 %define font_application_path    /usr/share/app_fonts/
 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
-%define dali_plugin_sound_files  %{dali_data_ro_dir}/plugins/sounds/
+%endif
 
+%define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
+%define dali_plugin_sound_files  %{dali_data_ro_dir}/plugins/sounds/
 %define dev_include_path %{_includedir}
 
 ##############################
@@ -255,6 +284,9 @@ FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
+%if 0%{?tizen_platform_config_supported}
+TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
+%endif
 
 # Default to GLES 2.0 if not specified.
 %{!?target_gles_version: %define target_gles_version 20}
@@ -297,9 +329,6 @@ rm -rf %{buildroot}
 cd build/tizen
 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
 
-# LICENSE
-mkdir -p %{buildroot}/usr/share/license
-cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
 
 ##############################
 # Upgrade order:
@@ -373,7 +402,7 @@ exit 0
 %defattr(-,app,app,-)
 %dir %{user_shader_cache_dir}
 %{_bindir}/*
-%{_datadir}/license/%{name}
+%license LICENSE
 
 %files devel
 %defattr(-,root,root,-)
@@ -402,5 +431,6 @@ exit 0
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libdali-video-player-plugin.so*
+%license LICENSE
 %endif
 %endif