Add features to download images over http protocol.
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor-wearable.spec
index d9bf582..8ed97ec 100644 (file)
@@ -1,6 +1,6 @@
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.0.21
+Version:    1.0.29
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0
@@ -9,6 +9,8 @@ Source0:    %{name}-%{version}.tar.gz
 
 %define dali_profile WEARABLE
 %define dali_wearable_profile 1
+%define dali_feedback_plugin 0
+%define dali_assimp_plugin 0
 
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
@@ -41,6 +43,11 @@ BuildRequires:  pkgconfig(capi-system-system-settings)
 BuildRequires:  pkgconfig(libpng)
 BuildRequires:  pkgconfig(gles20)
 BuildRequires:  pkgconfig(efl-assist)
+BuildRequires:  libcurl-devel
+
+%if 0%{?dali_assimp_plugin}
+BuildRequires:  pkgconfig(assimp)
+%endif
 
 %description
 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
@@ -63,10 +70,12 @@ Development components for the DALi Tizen Adaptor - public headers and package c
 %package dali-feedback-plugin
 Summary:    Plugin to play haptic and audio feedback for Dali
 Group:      System/Libraries
+%if 0%{?dali_feedback_plugin}
 Requires:       libdeviced
 BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(deviced)
 BuildRequires:  libfeedback-devel
+%endif
 
 %description dali-feedback-plugin
 Feedback plugin to play haptic and audio feedback for Dali
@@ -97,12 +106,6 @@ PREFIX+="/usr"
 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections "
 
-%if 0%{?sec_build_binary_debug_enable}
-export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
-export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
-export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
-%endif
-
 %ifarch %{arm}
 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
 %endif
@@ -117,7 +120,14 @@ FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
 FONT_APPLICATION_PATH="%{font_application_path}" ; export FONT_APPLICATION_PATH
 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
 
-%configure --with-jpeg-turbo --enable-gles=30 --enable-profile=%{dali_profile} --libdir=%{_libdir}
+%configure --with-jpeg-turbo --enable-gles=20 --enable-profile=%{dali_profile} \
+%if 0%{?dali_feedback_plugin}
+           --enable-feedback \
+%endif
+%if 0%{?dali_assimp_plugin}
+           --enable-assimp \
+%endif
+           --libdir=%{_libdir}
 
 make %{?jobs:-j%jobs}