Revert "Add dependency of nghttp2-devel"
[platform/upstream/curl.git] / packaging / curl.spec
index eb90041..dc405a2 100644 (file)
@@ -1,6 +1,6 @@
 Name:       curl
 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
-Version:    7.48.0
+Version:    7.53.1
 Release:    1
 Group:      Applications/Internet
 License:    MIT
@@ -14,6 +14,7 @@ BuildRequires:  pkgconfig(libidn)
 BuildRequires:  pkgconfig(zlib)
 BuildRequires:  pkgconfig(libcares)
 BuildRequires: pkgconfig(libnghttp2)
+
 Provides:   webclient
 
 
@@ -61,13 +62,14 @@ cp %{SOURCE1001} .
 
 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
 
-%if "%{?profile}" == "tv"
+%if "%{TIZEN_PROFILE_TV}" == "1"
 CFLAGS+=" -DTIZEN_TV_EXT"
 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
 %else
 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
 %endif
---with-ca-path=/etc/ssl/certs \
+--with-ca-path==/etc/ssl/certs \
+--with-ca-bundle=/etc/ssl/ca-bundle.pem \
 --with-libidn \
 --with-lber-lib=lber \
 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
@@ -102,22 +104,18 @@ install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 
-# LICENSE
-rm -rf %{buildroot}/usr/share/license
-mkdir -p %{buildroot}/usr/share/license
-cp COPYING %{buildroot}/usr/share/license/%{name}
-
 %post -n libcurl -p /sbin/ldconfig
 
 %postun -n libcurl -p /sbin/ldconfig
 
 %files
 %{_bindir}/curl
+%license COPYING
 
 %files -n libcurl
 %manifest %{name}.manifest
 %{_libdir}/libcurl.so.*
-/usr/share/license/%{name}
+%license COPYING
 
 %files -n libcurl-devel
 %{_bindir}/curl-config*