Revert "Add dependency of nghttp2-devel"
[platform/upstream/curl.git] / packaging / curl.spec
index 56a2eaa..dc405a2 100644 (file)
@@ -1,29 +1,30 @@
 Name:       curl
 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
-Version:    7.40.1
+Version:    7.53.1
 Release:    1
 Group:      Applications/Internet
 License:    MIT
 URL:        http://curl.haxx.se/
 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
 Source0:    %{name}-%{version}.tar.gz
+Source1001:     %{name}.manifest
 
 BuildRequires:  pkgconfig(openssl)
 BuildRequires:  pkgconfig(libidn)
 BuildRequires:  pkgconfig(zlib)
 BuildRequires:  pkgconfig(libcares)
 BuildRequires: pkgconfig(libnghttp2)
+
 Provides:   webclient
 
 
 %description
-cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,
-DICT, TELNET and TFTP servers, using any of the supported protocols.
-cURL is designed to work without user interaction or any kind of
-interactivity. cURL offers many useful capabilities, like proxy support,
-user authentication, FTP upload, HTTP post, and file transfer resume.
-
+curl is a client to get documents/files from servers, using any of the
+supported protocols. The command is designed to work without user
+interaction or any kind of interactivity.
 
+curl offers a busload of useful tricks like proxy support, user
+authentication, ftp upload, HTTP post, file transfer resume and more.
 
 %package -n libcurl
 Summary:    A library for getting files from web servers
@@ -47,15 +48,12 @@ Provides:   curl-devel = %{version}-%{release}
 Obsoletes:   curl-devel < %{version}-%{release}
 
 %description -n libcurl-devel
-cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
-Dict servers, using any of the supported protocols. The libcurl-devel
-package includes files needed for developing applications which can
-use cURL's capabilities internally.
-
-
+libcurl is the core engine of curl; this packages contains all the libs,
+headers, and manual pages to develop applications using libcurl.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 #%patch01 -p1
 #%patch02 -p1
@@ -64,18 +62,20 @@ use cURL's capabilities internally.
 
 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
 
-%if "%{?tizen_profile_name}" == "tv"
+%if "%{TIZEN_PROFILE_TV}" == "1"
 CFLAGS+=" -DTIZEN_TV_EXT"
 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
 %else
 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
 %endif
---with-ca-path=/etc/ssl/certs \
+--with-ca-path==/etc/ssl/certs \
+--with-ca-bundle=/etc/ssl/ca-bundle.pem \
 --with-libidn \
 --with-lber-lib=lber \
 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
 --disable-static \
 --with-nghttp2 \
+--without-zsh-functions-dir \
 
 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
 
@@ -104,22 +104,18 @@ install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 
-# LICENSE
-rm -rf %{buildroot}/usr/share/license
-mkdir -p %{buildroot}/usr/share/license
-cp COPYING %{buildroot}/usr/share/license/%{name}
-
 %post -n libcurl -p /sbin/ldconfig
 
 %postun -n libcurl -p /sbin/ldconfig
 
 %files
 %{_bindir}/curl
+%license COPYING
 
 %files -n libcurl
 %manifest %{name}.manifest
 %{_libdir}/libcurl.so.*
-/usr/share/license/%{name}
+%license COPYING
 
 %files -n libcurl-devel
 %{_bindir}/curl-config*