Update to 7.50.2
[platform/upstream/curl.git] / packaging / curl.spec
index 2923628..6733f54 100644 (file)
@@ -1,33 +1,36 @@
 Name:       curl
 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
-Version:    7.21.3
+Version:    7.50.2
 Release:    1
 Group:      Applications/Internet
 License:    MIT
-#URL:        http://curl.haxx.se/
+URL:        http://curl.haxx.se/
 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-Source0:    %{name}-%{version}.tar.bz2
+Source0:    %{name}-%{version}.tar.gz
+Source1001:     %{name}.manifest
 
 BuildRequires:  pkgconfig(openssl)
 BuildRequires:  pkgconfig(libidn)
-BuildRequires:  pkgconfig(nss)
 BuildRequires:  pkgconfig(zlib)
 BuildRequires:  pkgconfig(libcares)
+BuildRequires: pkgconfig(libnghttp2)
 Provides:   webclient
 
 
 %description
-cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,
-DICT, TELNET and TFTP servers, using any of the supported protocols.
-cURL is designed to work without user interaction or any kind of
-interactivity. cURL offers many useful capabilities, like proxy support,
-user authentication, FTP upload, HTTP post, and file transfer resume.
-
+curl is a client to get documents/files from servers, using any of the
+supported protocols. The command is designed to work without user
+interaction or any kind of interactivity.
 
+curl offers a busload of useful tricks like proxy support, user
+authentication, ftp upload, HTTP post, file transfer resume and more.
 
 %package -n libcurl
 Summary:    A library for getting files from web servers
 Group:      System/Libraries
+License:    MIT
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
 
 %description -n libcurl
 This package provides a way for applications to use FTP, HTTP, Gopher and
@@ -37,33 +40,40 @@ other servers for getting files.
 %package -n libcurl-devel
 Summary:    Files needed for building applications with libcurl
 Group:      Development/Libraries
+License:    MIT
 Requires:   libcurl = %{version}-%{release}
 Requires:   libidn-devel
 Provides:   curl-devel = %{version}-%{release}
 Obsoletes:   curl-devel < %{version}-%{release}
 
 %description -n libcurl-devel
-cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
-Dict servers, using any of the supported protocols. The libcurl-devel
-package includes files needed for developing applications which can
-use cURL's capabilities internally.
-
-
+libcurl is the core engine of curl; this packages contains all the libs,
+headers, and manual pages to develop applications using libcurl.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
+#%patch01 -p1
+#%patch02 -p1
 
 %build
 
-export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT"
+export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
 
+%if "%{TIZEN_PROFILE_TV}" == "1"
+CFLAGS+=" -DTIZEN_TV_EXT"
 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
+%else
+%reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
+%endif
 --with-ca-path=/etc/ssl/certs \
 --with-libidn \
 --with-lber-lib=lber \
 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
---disable-static
+--disable-static \
+--with-nghttp2 \
+--without-zsh-functions-dir \
 
 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
 
@@ -92,6 +102,11 @@ install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 
+# LICENSE
+rm -rf %{buildroot}/usr/share/license
+mkdir -p %{buildroot}/usr/share/license
+cp COPYING %{buildroot}/usr/share/license/%{name}
+
 %post -n libcurl -p /sbin/ldconfig
 
 %postun -n libcurl -p /sbin/ldconfig
@@ -100,7 +115,9 @@ rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 %{_bindir}/curl
 
 %files -n libcurl
+%manifest %{name}.manifest
 %{_libdir}/libcurl.so.*
+/usr/share/license/%{name}
 
 %files -n libcurl-devel
 %{_bindir}/curl-config*
@@ -109,4 +126,3 @@ rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 %{_libdir}/pkgconfig/*.pc
 %{_datadir}/aclocal/libcurl.m4
 
-