Enable ipv6 for TV profile
[platform/upstream/curl.git] / packaging / curl.spec
index 8a23d3a..645939e 100644 (file)
@@ -1,6 +1,6 @@
 Name:       curl
 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
-Version:    7.53.1
+Version:    7.59.0
 Release:    1
 Group:      Applications/Internet
 License:    MIT
@@ -9,12 +9,11 @@ URL:        http://curl.haxx.se/
 Source0:    %{name}-%{version}.tar.gz
 Source1001:     %{name}.manifest
 
-BuildRequires:  pkgconfig(glib-2.0)
+BuildRequires:  pkgconfig(icu-uc)
 BuildRequires:  pkgconfig(openssl)
 BuildRequires:  pkgconfig(zlib)
 BuildRequires:  pkgconfig(libcares)
 BuildRequires: pkgconfig(libnghttp2)
-
 Provides:   webclient
 
 
@@ -43,7 +42,6 @@ Summary:    Files needed for building applications with libcurl
 Group:      Development/Libraries
 License:    MIT
 Requires:   libcurl = %{version}-%{release}
-Requires:   glib2-devel
 Provides:   curl-devel = %{version}-%{release}
 Obsoletes:   curl-devel < %{version}-%{release}
 
@@ -51,6 +49,15 @@ Obsoletes:   curl-devel < %{version}-%{release}
 libcurl is the core engine of curl; this packages contains all the libs,
 headers, and manual pages to develop applications using libcurl.
 
+%package -n libcurl-extension-dlp
+Summary:       Extensions for Tizen OS
+Provides:      libcurl-extension-dlp = %{version}-%{release}
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description -n libcurl-extension-dlp
+libcurl extensions for Tinen OS.
+
 %prep
 %setup -q
 cp %{SOURCE1001} .
@@ -61,21 +68,22 @@ cp %{SOURCE1001} .
 %build
 
 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
-
-%if "%{TIZEN_PROFILE_TV}" == "1"
+CFLAGS+=" -fstack-protector-strong -Wl,-z,relro -D_FORTIFY_SOURCE=2 -fPIE -pie"
+%if "%{tizen_profile_name}" == "tv"
 CFLAGS+=" -DTIZEN_TV_EXT"
-%reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
+%reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
 %else
 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
 %endif
 --with-ca-path==/etc/ssl/certs \
 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
---with-glib2 \
+--with-icu-uc \
 --with-lber-lib=lber \
 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
 --disable-static \
 --with-nghttp2 \
 --without-zsh-functions-dir \
+--enable-dlp \
 
 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
 
@@ -95,7 +103,7 @@ rm -rf $RPM_BUILD_ROOT
 
 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
 
-rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
+rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl{,_extension_dlp}.la
 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
 
@@ -124,3 +132,7 @@ rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 %{_libdir}/pkgconfig/*.pc
 %{_datadir}/aclocal/libcurl.m4
 
+%files -n libcurl-extension-dlp
+%manifest %{name}.manifest
+%{_libdir}/libcurl_extension_dlp.so.*
+%license COPYING